Closed Bug 1266717 Opened 5 years ago Closed 5 years ago

Add a --with-sccache configure option

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1318370

People

(Reporter: ted, Assigned: ted)

References

(Blocks 1 open bug)

Details

Right now you can use sccache locally but it requires adding a bunch of stuff to your mozconfig:
https://glandium.org/blog/?p=3275
```
ac_add_options "--with-compiler-wrapper=python2.7 path/to/sccache/sccache.py"
export _DEPEND_CFLAGS='-deps$(MDDEPDIR)/$(@F).pp'
mk_add_options "export CC_WRAPPER="
mk_add_options "export CXX_WRAPPER="
mk_add_options "export COMPILE_PDB_FLAG="
mk_add_options "export HOST_PDB_FLAG="
mk_add_options "export MOZ_DEBUG_FLAGS=-Z7"

```

We should just add a `--with-sccache[=path]` to make this work out-of-the-box.
I made `--with-ccache` handle sccache in bug 1286934, but I filed bug 1318370 on the rest of it.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1318370
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.