Closed Bug 126679 Opened 23 years ago Closed 23 years ago

"Download More" Content Packs doesn't do anything

Categories

(Core :: Internationalization: Localization, defect)

x86
Linux
defect
Not set
major

Tracking

()

CLOSED WORKSFORME

People

(Reporter: bootsy52, Assigned: dbragg)

Details

Attachments

(1 file)

Todays build Feb 20th 2002 I remarked, that when you go
Edit->Preferences->Appearance->Content Packs and hit the Download More button it
actually happens nothing. Tried several times, but hitting the button simply has
no effect.

Compiled with:

ac_add_options --prefix=/usr/lib/mozilla-097
ac_add_options --libdir=/usr/lib/mozilla-097
ac_add_options --includedir=/usr/include/mozilla-097
ac_add_options --enable-crypto
ac_add_options --disable-accessibility
ac_add_options --enable-mathml
ac_add_options --enable-svg
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize="-O3 -march=i686 -mcpu=i686"
ac_add_options --disable-dtd-debug
ac_add_options --enable-strip
ac_add_options --with-default-mozilla-five-home=/usr/lib/mozilla-097
ac_add_options --with-user-appdir=".mozilla-098"
ac_add_options --enable-static
ac_add_options --disable-shared
I can confirm this bug on a build from today, too.

I'm getting an error on JavaScript Console as well when clicking on the button:
Error: DownloadRegionPacks is not defined

This also seems to be caused by the checkin for bug 91721 - reassigning to 
dbragg@netscape.com and CCing tao.
Assignee: kairo → dbragg
Status: UNCONFIRMED → NEW
Component: German-Austria/de-AT → Localization
Ever confirmed: true
Product: Browser Localizations → Browser
Version: unspecified → other
QA Contact: Sebastian → jimmyu
This is very strange.  Yes, I changed a lot in the pref-contentpacks.xul file
but where DownloadRegionPacks is defined and called was "unchanged". I'm having
to do a new pull and build of the mozilla tree since so much changed last night.
 I am seeing the problem on the downloaded builds though.  I'll need this debug
build to find out what's happening though.
Found it.  It's not in the DownloadRegionPacks declaration or call.  It's
further up.  Somehow a parenthesis got left off on the var regionElements line.
 This affected everything downstream.  Posting patch.
Status: NEW → ASSIGNED
A paren got left off.  It got left off prior to posting the patch for 92721 but
all us reviewers missed it.  *sigh*
Comment on attachment 70603 [details] [diff] [review]
Re-added the parenthesis that should have been there.

sr=alecf
Attachment #70603 - Flags: superreview+
Comment on attachment 70603 [details] [diff] [review]
Re-added the parenthesis that should have been there.

r=tao
Attachment #70603 - Flags: review+
a=asa (on behalf of drivers) for checkin to 0.9.9
Keywords: mozilla0.9.9+
Just to note that beside this bug, also bug 119450 still exists for me. As I
couldn't use the "Download More" Button I clicked directly on:

http://www.mozilla.org/projects/l10n/mlp_status.html#moz_0.98

I think it would not be good to let this go into 0.99.
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
Verified with Mozilla Trunk ID 2002022203.
Status: RESOLVED → VERIFIED
Does not work again:

Used CVS Trunk

March 3rd 2002 10:00 I get this erro in Javascript Console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.focus]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://communicator/content/utilityOverlay.js :: openTopWin :: line 254" 
data: no]

Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Verified this problem on Linux build, but both Windows and Mac build are fine.
The latest Linux build 20020311 (0.9.9 branch and trunk) works fine in regards
to the download button. It also works the Win32 and Mac builds.

Marking WFM.
Status: REOPENED → RESOLVED
Closed: 23 years ago23 years ago
Resolution: --- → WORKSFORME
Confirm, works for me as well again. Hope that it stays like this
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: