If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pine version of Mulet is not loading the gaia profile

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: nhirata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8744454 [details]
console output of mach run

1. make profile in gaia directory
2. MOZCONFIG=mulet ./mach build in pine directory
3. MOZCONFIG=mulet ./mach run -profile ../gaia/profile

Expected Mulet loads
Actual : 
(process:21444): GLib-CRITICAL **: g_path_get_basename: assertion 'file_name != NULL' failed
Blocks: 1245091
To note, I think the same is happening for the unit tests?  
https://tools.taskcluster.net/task-graph-inspector/#EByFGCYtRlaggpWhgCl8dA/

The state says complete, but the satisfied says no.
Maybe I'm interpreting this wrong?
Duplicate of Bug 1263308?
Flags: needinfo?(aus)
I have no problem with latest pine.
I'm not sure what the issue is, with the latest pine after doing a `make clean && make PRODUCTION=1 GAIA_OPTIMIZE=1 MOZILLA_OFFICIAL=1 profile` and then doing a 
./mach clobber and MOZCONFIG=mulet ./mach build and MOZCONFIG=mulet ./mach run -profile ../gaia/profile

I was able to run again.

It's possibly the clobber that I needed to do.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME

Comment 5

a year ago
Clearing NI since we've figured this out. :)
Flags: needinfo?(aus)
You need to log in before you can comment on or make changes to this bug.