Loading page from Tasks | Tools | History window fails

VERIFIED FIXED

Status

()

Core
History: Global
--
blocker
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: tracy, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({smoketest})

Trunk
smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
seen on commercail builds:

windows 2002-02-20-06-trunk
linux 2002-02-20-06-trunk
mac osx 2002-02-20-03-trunk

-Browse a few random pages
-Go to Task | Tools | History
-From the window, double click a site

the page doesn't load into the browser window as expected.

blocker
(Reporter)

Updated

16 years ago
Keywords: smoketest

Comment 1

16 years ago
-> ben. I assume this is yours. I told you to back that stuff out. Now suffer 
the consequences! <insert evil laugh>
Assignee: blaker → ben

Comment 2

16 years ago
Looking at the code, I'm fairly certain the problem is just that ben removed the 
declaration of builder in history.js' OpenURL.  I don't know if Ben is around 
right now, it doesn't look like it, so let's not hold for this.

If someone can try readding that line, that would be good.  Ben's changes to 
history should be backed out anyway (except for the addition of the stylesheet).
Severity: blocker → critical

Comment 3

16 years ago
sheriff's note:
restored original severity to "blocker".

I'd like to see more resolution here before we downgrade this. After reading
blaker's last commment, we need to do one of three things:
1) try the one line fix, or otherwise fix it.
2) back out Ben's code
or 3) come up with a convincing argument as to why this isn't a blocker.
Severity: critical → blocker

Comment 4

16 years ago
I am home now and will try the one line fix.

However, backing out the history patch is the right thing to do anyway. I
advised doing that last night.  The main reason to hold the tree for a blocker
is to make sure that everyone is looking into it.  Given that we basically had a
fix, there was no reason to make everyone wait. That's why I downgraded it.
I've checked in a fix. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Keywords: nsbeta1+

Comment 6

16 years ago
VERIFIED Fixed 2002030803 builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.