bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Correct small Javascript logic error in InputWidgetHelper

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: capella, Unassigned, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug] [lang=js])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
This is a fairly simple bug for a new contributor with basic Javascript skills, to learn the Mozilla Mobile development process. Estimated completion time should be easily less than two weeks, and more likely less than one.

You should have an android device for testing your solution locally, and should be able to build Firefox Mobile on your desktop. See [0] for instructions if this is new to you, and ask questions on irc channels #introduction, or #mobile.

THE PROBLEM, is that while repeatedly long-pressing into the empty search field on the PAGE [1], on a tablet, I can observe the ERROR [2] in the LOGCAT.

(I didn't this try on a phone but expect it should fail there, too.)

This indicates a problem at this LINE [3] in this METHOD. Please identify it, and provide a solution.


[0] https://wiki.mozilla.org/Mobile/Fennec/Android

[1] https://duckduckgo.com/
[2] Error: "TypeError: aElement.getAttribute is not a function" {file: "chrome://browser/content/InputWidgetHelper.js" line: 69}]
[3] http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/InputWidgetHelper.js?rev=52a402b0f7bc&mark=65-65,69-69#65

Comment 1

2 years ago
I want to work on this bug . Please assign it to me .

Comment 2

2 years ago
Hello, I am interested in working on this bug, can you help how should I proceed ahead?

Updated

2 years ago
Flags: needinfo?(markcapella)
(Reporter)

Comment 3

2 years ago
For any interested contributors, the basic description in comment #0 above should be enough to solve for.

We don't usually assign bugs to someone until they can demonstrate a solution or sufficient understanding to be easily able to complete one.

So until then... if you're extremely new, you may need faster help in irc channel #introduction, as mentioned above. They'll push you to complete a first-build, start testing, and etc.

For Android specific questions in building / testing, irc channel #mobile is more specialized.

If you think you have a solution, tell us what you've done so far, and where you're stuck.
Flags: needinfo?(markcapella)

Comment 4

2 years ago
Created attachment 8756453 [details]
mylog.txt

Hi Mark,

I tried to simulate the issue after deploying the apk on my Nexus 5. However, the logcat generated does not contain the error message "TypeError: aElement.getAttribute is not a function".

Comment 5

2 years ago
Created attachment 8756482 [details]
newlog.txt

Here's another logcat captured after testing with same apk file on Galaxy Nexus emulator. Still no clue on the error message.
(Reporter)

Comment 6

2 years ago
Yes, I can't repro this anymore either. DDG may have redesigned here a bit.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.