Closed Bug 126714 Opened 23 years ago Closed 23 years ago

Can't switch Languages or Web Content

Categories

(Core :: Internationalization: Localization, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED INVALID

People

(Reporter: kairo, Assigned: dbragg)

Details

(Keywords: intl)

Attachments

(1 file)

In today's build (source pulled around 2002-02-20-06), I have a current German
(de-AT) Langauge Pack (I just built that pack from this build's en-US files).

1) The German pack is shown as "(needs update)" though it has
localeVersion="0.9.9" in its contents.rdf as well as in my chrome.rdf files.

2) If I select either English/US or German from the new pref panel's list and
restart moz, nothing has changed. The Langauge does not switch to either of
those, samne with content packs.

3) If I change the profile's chrome.rdf manually, Mozilla applies the Language
correctly.

I assume somehow the new pref panel checked in for bug 91721 is broken.

Assigning this to dbragg@netscape.com, who did this patch.
CCing Tao from L10n team.
You can find the de-AT files which should work with 2002-02-20-06 for testing
purposes at http://www.hirsch.sth.ac.at/mozilla/de-AT-2002-02-20-06.xpi
Does your english pack show up correctly?

What "manual" change did you make to the chrome.rdf file?
Keywords: intl
QA Contact: ruixu → jimmyu
The English/US packs show up in the panels as they should, and both the English
and German files do work when I do the manual changes.

The manual changes I do is changing e.g.
<c:selectedLocale resource="urn:mozilla:locale:en-US:navigator"/>
to
<c:selectedLocale resource="urn:mozilla:locale:de-AT:navigator"/>
and back in my profile's chrome.rdf

This shows that the packs are working fine in the backend.

I got another bug reported about this panel, that bug 126679 might be related to
those changes as well.
Thank you Robert. I have another question.  What kind of installer is this? It
looks like you're installing both a language and region pack in a single
installer.  Is that true?
Yes, it's true that I'm installing both at once here.
On, my build, I installed all packs long ago though, and just replaced the .jar
and corrected all localeVersion strings to 0.9.9 today :)
This worked perfectly with the "old" dropdown in the Appearance panel but broke
with the new listbox :(
I thought that might be the case.  I'm not saying this shouldn't work at this
point.  I'm just trying to eliminate all the variables.  I'm creating a "german
language" installer out of the english installer that was created with the
build. I put the quotes in because it'll just be the english files with the
en-US strings changed to de-DE.  This is how I tested the code in the first
place although I used italian.  It seemed to work just fine for my tests.
Robert, I have some more information.  You need to check your contents.rdf file
in the global directory.  It must have localeVersion=0.9.9 in it.  If it doesn't
you'll get the "(needs update)" tag.

I've constructed my own langede.xpi file that is based on the langenus.xpi file.
 When I install it the new lang pack shows up correctly.  In working with
Jimmyu, I found that the localization tool doesn't put this in the new .jar file
(de-DE.jar in my case) correctly.  It's in the english one but not in any new
ones created with the tool.  I'm looking in to the with Jimmy.  Is this by any
chance how you created your installer?
Status: NEW → ASSIGNED
I should clarify my last statement.  You need to make sure BOTH localeVersion
values have been updated to 0.9.9 as in this attachment.  If your contents.rdf
file only has one localeVersion variable it's an old version or the tool used
to create a new .jar file isn't working correctly.
Thanks for pointing this out. I am creating/modifying my contents.rdf files with
a script I wrote because MozillaTranslator 4.36 does not insert any localeVersion :(
And I didn't know about this "global" localeVersion part.
(I updated the pack on the posted URL to be include this)

Anyway, the core of this bug still remains when I update my packs correctly. The
"(needs update)" part is gon now but:

1) The panel does not notify me in any way which pack is currently selected

2) When I select any pack there (langauge and/or content) and restart Mozilla,
the selected pack is NOT applied.
oops, BTW, fix summary typo :)
Summary: Can't switch Langauges or Web Content → Can't switch Languages or Web Content
I was going to log a separate bug for showing currently selected packs as that
is a new "feature".

On the other subject of not actually having the pack change, I'm afraid it's
working for me.  I changed finddialog.dtd in my de-DE.jar file, then selected my
fake german language pack and when I selected Search/Find in this page, the Find
dialog had my changes in it.  Have you been able to update your .xpi file with
the correct localeVersion stuff?  Can you send it to me?  I'll take a look at it.
As I said, the new version of the files, including the additional localeVersion
info, is now at http://www.hirsch.sth.ac.at/mozilla/de-AT-2002-02-20-06.xpi
Progress!
Robert, I installed your latest .xpi file and if you use the latest Mozilla
build the Deutsch (Osterreich) pack shows up correctly and when I select it I
get the German-Austrian menus, buttons etc.  The reason this now works is that I
checked in a fix for a bug yesterday regarding the Download More button.  Well,
that problem was causing the selection of a language pack to not be applied.

On the other pack, (Inhalte Osterreich) I'm still not seeing the localeVersion
string in the chrome.rdf file for this section.  I believe that when this is
corrected this pack should work as well.
I have corrected the content pack, and both packs are working/switching now as
they should, so I think it was fixed with the checkin for bug 126679 - like you
said.
Ok, thanks Robert.  I'm going to mark this bug invalid then.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → INVALID
Mark verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: