IME status tip's position is wrong in search input on menu

VERIFIED INVALID

Status

()

VERIFIED INVALID
3 years ago
2 years ago

People

(Reporter: baffclan, Unassigned)

Tracking

({inputmethod})

Trunk
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8744863 [details]
Screenshot

Steps to Reproduce:
1. Start Nightly
2. Focused Search input on menu
3. type "12345678901234567890" and select it
4. Changed IME status
5. Appear IME status tip

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160424030601
Maybe, reporter uses Google Japanese IME.  But I cannot reproduce this on Windows 10 + Nightly7 + Google IME.
Component: General → Widget: Win32
On Win7, Google Japanese Input is installed as IMM API.
s/IMM API/IMM IME
(Reporter)

Comment 4

3 years ago
Yes, I used Google Japanese Input, it is Developer version.
GoogleJapaneseInput-2.18.2470.100
(Reporter)

Comment 5

3 years ago
Reproduce on Vivaldi, Opera, Google Chrome and Internet Explorer.

Vivaldi 1.1.453.45 (Developer Build) (64 ビット)
Opera Developer 38.0.2205.0
Google Chrome 50.0.2661.87 m (64-bit)
Internet Explorer 11.0.9600.18230
If this reproduces on all browsers, then it is probably a problem with Google Japanese Input Developer version, not Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
I guess that you disable TSF mode, no? In my experience, Google Japanese Input doesn't show input mode popup when queried character rect is outside the editor rect.

According to your screenshot, Google Japanese Input queries first character's rect of selection and it's scrolled out from the editor's rect. Therefore, the position is outside the editor.

So, yes, marking as INVA is reasonable.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.