Closed Bug 1267270 Opened 4 years ago Closed 3 years ago

SourceRepository and SourceStamp of [App] section in application.ini is wrong again

Categories

(Thunderbird :: Build Config, defect)

47 Branch
x86_64
All
defect
Not set

Tracking

(thunderbird45 unaffected, thunderbird46 unaffected, thunderbird47 wontfix, thunderbird48 wontfix, thunderbird49 fixed, thunderbird50 fixed, thunderbird_esr45 unaffected, thunderbird51 fixed)

RESOLVED FIXED
Thunderbird 51.0
Tracking Status
thunderbird45 --- unaffected
thunderbird46 --- unaffected
thunderbird47 --- wontfix
thunderbird48 --- wontfix
thunderbird49 --- fixed
thunderbird50 --- fixed
thunderbird_esr45 --- unaffected
thunderbird51 --- fixed

People

(Reporter: alice0775, Assigned: aleth)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

+++ This bug was initially created as a clone of Bug #1068100 +++

The problem appears again on 47.0a2 and later.

SourceRepository and SourceStamp are wrong.
Name, CodeName and ID are correct.


Steps To Reproduce:
1. Download Thunderbird latest-comm-aurora and latest-comm-central from http://archive.mozilla.org/pub/thunderbird/nightly/

2. Install it
3. Open Installed folder
4. Open application.ini 
5. See SourceRepository and SourceStamp

Actual Results:
SourceRepository and SourceStamp is mozilla-central's or mozilla-aurora's one

Expected Results:
Should be comm-central's or comm-aurora's one
OS: Windows 7 → All
Flags: needinfo?(mh+mozilla)
c-c would need to set MOZ_SOURCE_REPO and MOZ_SOURCE_CHANGESET in its configure script.
Flags: needinfo?(mh+mozilla)
Blocks: 1267465
Duplicate of this bug: 1267465
(In reply to Alice0775 White from comment #1)
> Regression window:
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=576a6dcde5b68c2ea45324ed5ce1dabb7d833d09&tochange=d719
> ac4bcbec13e0ba13a41547788e3bf365c679
> https://hg.mozilla.org/comm-central/
> pushloghtml?fromchange=fa658e89c63a&tochange=01d0cf9ebf8d
> 
> Suspect: Bug 1224450, Bug 1247162, Bug 1241613, Bug 1246881

Via local build,
Regressed by:
	51029f4d82d3	Mike Hommey — Bug 1247162 - Generate a header defining MOZ_SOURCE_*. r=mshal
Blocks: 1247162
Magnus, can you please comment whether this bug should block 47.0b1?
Flags: needinfo?(mkmelin+mozilla)
Duplicate of this bug: 1262452
Blocks: 1222878
aleth added bug 1222878 as a dependency

So I suppose we wont' have any localized builds until this is fixed. Not sure that's a firm blocker for a beta at this moment, but obviously important to sort out.
Flags: needinfo?(mkmelin+mozilla)
47.0b1 is failing in repacks. Is that this bug?
(In reply to Kent James (:rkent) from comment #8)
> 47.0b1 is failing in repacks. Is that this bug?

If it fails during configure, it's bug 1267523. If it fails during 'hg update ...', it's this one. If it's neither...
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8779835 - Attachment is obsolete: true
Attachment #8779835 - Flags: review?(mh+mozilla)
Does lightning also need some code removal?
Flags: needinfo?(aleth)
(In reply to Ian Neal (Away until 7th Aug) from comment #12)
> Does lightning also need some code removal?

I'd say yes (in calendar/lightning/Makefile.in).
Flags: needinfo?(aleth)
Attachment #8779842 - Flags: review?(mh+mozilla) → review+
(In reply to aleth [:aleth] from comment #11)
"s/^ssh:/http:/" should be "s/^ssh:/https:/"?
(In reply to Takanori MATSUURA from comment #14)
> (In reply to aleth [:aleth] from comment #11)
> "s/^ssh:/http:/" should be "s/^ssh:/https:/"?

Good idea, I'll update that before checkin.
I'll also follow Bug 1192068 in using long revision nodes.
https://hg.mozilla.org/comm-central/rev/b2b090d8d57e7608c0b015ab4c55ab69dc53b3aa
Bug 1267270 - Set MOZ_SOURCE_REPO and MOZ_SOURCE_CHANGESET to the appropriate values for comm-* in configure. r=glandium a=aleth CLOSED TREE DONTBUILD
Updated patch for future uplifts, r+ carried forward.
Attachment #8779842 - Attachment is obsolete: true
Attachment #8780524 - Attachment description: Set MOZ_SOURCE_REPO and MOZ_SOURCE_CHANGESET to the appropriate values for comm-* in configure. CLOSED TREE DONTBUILD → Set MOZ_SOURCE_REPO and MOZ_SOURCE_CHANGESET to the appropriate values for comm-* in configure.
Attachment #8780524 - Flags: review+
(In reply to aleth [:aleth] from comment #13)
> (In reply to Ian Neal (Away until 7th Aug) from comment #12)
> > Does lightning also need some code removal?
> 
> I'd say yes (in calendar/lightning/Makefile.in).

Since that file sets both SOURCE_* and MOZ_SOURCE_* I'm unsure of the right thing to do there, and will leave it to someone who knows calendar/ better.
Flags: needinfo?(iann_bugzilla)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 51.0
Comment on attachment 8780524 [details] [diff] [review]
Set MOZ_SOURCE_REPO and MOZ_SOURCE_CHANGESET to the appropriate values for comm-* in configure.

[Approval Request Comment]
Regression caused by (bug #): 1247162
Impact: incorrect source stamp data, problems with l10n builds.

Please wait with the uplift until we've had a couple of green builds on c-c.
Attachment #8780524 - Flags: approval-comm-beta?
Attachment #8780524 - Flags: approval-comm-aurora?
Blocks: 192068
Blocks: 1192068
No longer blocks: 192068
Is this one in the installer/makefile.in dirs for im, mail and suite still right?

>> APP_SOURCE_STAMP = $(firstword $(shell hg -R $(topsrcdir) parent --template="{node|short}\n" >> 2>/dev/null))
>> APP_SOURCE_REPO = $(shell hg -R $(topsrcdir) showconfig paths.default 2>/dev/null | sed -e 
>> "s/^ssh:/http:/")
>> make-sourcestamp-file::
>>	@echo "$(APP_SOURCE_REPO)/rev/$(APP_SOURCE_STAMP)" >> $(MOZ_SOURCESTAMP_FILE)
(In reply to Frank-Rainer Grahl from comment #21)
I don't think anything has changed around MOZ_SOURCESTAMP_FILE ? If it did, that would be for another bug.
Yes. Just aren't sure because its using the same logic and might now also point to the m-x repositories. The file seems to be only used for uploads.

Suite builds correctly with your patch. application.ini and platform.ini looks fine and now points to c-c.
Shouldn't contain the platform.ini the scource-ID from mozilla-central?
(In reply to Alfred Peters from comment #24)
> Shouldn't contain the platform.ini the scource-ID from mozilla-central?

I hadn't checked platform.ini, but it looks like you are right. I don't know if there's a simple way to fix this.
Flags: needinfo?(mh+mozilla)
Duplicate of this bug: 1259685
It's actually quite sad that comm-central is not using an actual subrepo, which would make the comm-central revision self sufficient. cc-merge is also supposed to happen at some point, effectively making the distinction impossible. So, while it might be nice to have platform.ini use m-c's source-id, I'm not convinced we should go through hoops to make it happen (especially if it's doomed to fail at some point in the future).
Flags: needinfo?(mh+mozilla)
(In reply to Mike Hommey [:glandium] from comment #27)
> It's actually quite sad that comm-central is not using an actual subrepo,
> which would make the comm-central revision self sufficient. cc-merge is also
> supposed to happen at some point, effectively making the distinction
> impossible. So, while it might be nice to have platform.ini use m-c's
> source-id, I'm not convinced we should go through hoops to make it happen
> (especially if it's doomed to fail at some point in the future).

Yes, the two-repo c-c build system is a continuing source of pain. Unfortunately attempts to cc-merge so far have not been successful. I'm needinfoing jcranmer to update you on the current state of play here.

I'm unsure if there are any steps in automation that depend on a correct platform.ini m-c reference. At the very least it makes debugging harder to not include that information in builds.
Flags: needinfo?(Pidgeot18)
Attachment #8780524 - Flags: approval-comm-beta?
Attachment #8780524 - Flags: approval-comm-beta+
Attachment #8780524 - Flags: approval-comm-aurora?
Attachment #8780524 - Flags: approval-comm-aurora+
(In reply to aleth [:aleth] from comment #28)
> Yes, the two-repo c-c build system is a continuing source of pain.
> Unfortunately attempts to cc-merge so far have not been successful. I'm
> needinfoing jcranmer to update you on the current state of play here.

I've got the scripts to make it happen, and the last I checked, they worked flawlessly. What I don't have is the release and automation changes to make it happen, and I've lacked the time to round up what changes are needed.
Flags: needinfo?(Pidgeot18)
Depends on: 1297198
Depends on: 1300030
Flags: needinfo?(iann_bugzilla)
Blocks: 1322344
Depends on: 1361370
You need to log in before you can comment on or make changes to this bug.