Closed Bug 1267310 Opened 7 years ago Closed 7 years ago

Intermittent test_pointerevent_pointerleave_descendant_over-manual.html | pointerleave shouldn't be received on descendant's pointerover - got 1, expected +0

Categories

(Core :: DOM: Events, defect, P5)

Unspecified
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---
firefox48 --- affected

People

(Reporter: RyanVM, Assigned: stone)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

All Windows debug e10s so far, from what I'm seeing.

https://treeherder.mozilla.org/logviewer.html#?job_id=170650&repo=ash

05:56:43     INFO -  207 INFO TEST-START | dom/events/test/pointerevents/test_pointerevent_pointerleave_descendant_over-manual.html
05:56:43     INFO -  [Parent 904] WARNING: no triggering principal available via loadInfo, assuming load is cross-origin: file c:/builds/moz2_slave/ash-w32-d-00000000000000000000/build/src/netwerk/protocol/http/HttpBaseChannel.cpp, line 1405
05:56:43     INFO -  [Parent 904] WARNING: Found channel with no loadinfo, assuming third-party request: file c:/builds/moz2_slave/ash-w32-d-00000000000000000000/build/src/dom/base/ThirdPartyUtil.cpp, line 235
05:56:43     INFO -  ++DOMWINDOW == 67 (11A84800) [pid = 2544] [serial = 67] [outer = 0FCBC400]
05:56:43     INFO -  ++DOCSHELL 11A8B400 == 9 [pid = 2544] [id = 15]
05:56:43     INFO -  ++DOMWINDOW == 68 (11A8B800) [pid = 2544] [serial = 68] [outer = 00000000]
05:56:43     INFO -  ++DOMWINDOW == 69 (11A8BC00) [pid = 2544] [serial = 69] [outer = 11A8B800]
05:56:43     INFO -  [Parent 904] WARNING: no triggering principal available via loadInfo, assuming load is cross-origin: file c:/builds/moz2_slave/ash-w32-d-00000000000000000000/build/src/netwerk/protocol/http/HttpBaseChannel.cpp, line 1405
05:56:43     INFO -  [Parent 904] WARNING: Found channel with no loadinfo, assuming third-party request: file c:/builds/moz2_slave/ash-w32-d-00000000000000000000/build/src/dom/base/ThirdPartyUtil.cpp, line 235
05:56:43     INFO -  ++DOMWINDOW == 70 (0DC7C400) [pid = 2544] [serial = 70] [outer = 11A8B800]
05:56:43     INFO -  TEST-INFO | started process screenshot
05:56:44     INFO -  TEST-INFO | screenshot: exit 0
05:56:44     INFO -  208 INFO TEST-UNEXPECTED-FAIL | dom/events/test/pointerevents/test_pointerevent_pointerleave_descendant_over-manual.html | pointerleave shouldn't be received on descendant's pointerover - got 1, expected +0
05:56:44     INFO -      SimpleTest.is@SimpleTest/SimpleTest.js:268:5
05:56:44     INFO -      result_function@dom/events/test/pointerevents/mochitest_support_external.js:33:3
05:56:44     INFO -  Tests.prototype.notify_result/<@http://mochi.test:8888/resources/testharness.js:1865:21
05:56:44     INFO -  forEach@http://mochi.test:8888/resources/testharness.js:2519:17
05:56:44     INFO -  Tests.prototype.notify_result@http://mochi.test:8888/resources/testharness.js:1862:9
05:56:44     INFO -  Tests.prototype.result@http://mochi.test:8888/resources/testharness.js:1856:9
05:56:44     INFO -  Test.prototype.done@http://mochi.test:8888/resources/testharness.js:1490:9
05:56:44     INFO -  Test.prototype.step@http://mochi.test:8888/resources/testharness.js:1390:13
05:56:44     INFO -  test@http://mochi.test:8888/resources/testharness.js:496:9
05:56:44     INFO -      run/<@dom/events/test/pointerevents/pointerevent_pointerleave_descendant_over-manual.html:44:21
05:56:44     INFO -      synthesizeMouseAtPoint@SimpleTest/EventUtils.js:367:26
05:56:44     INFO -      synthesizeMouse@SimpleTest/EventUtils.js:326:10
05:56:44     INFO -      sendMouseEvent@dom/events/test/pointerevents/mochitest_support_external.js:76:5
05:56:44     INFO -      executeTest@dom/events/test/pointerevents/test_pointerevent_pointerleave_descendant_over-manual.html:22:9
05:56:44     INFO -      callExecute@dom/events/test/pointerevents/mochitest_support_internal.js:25:5
05:56:44     INFO -      Async*turnOnPointerEvents@dom/events/test/pointerevents/mochitest_support_external.js:21:3
05:56:44     INFO -      preExecute@dom/events/test/pointerevents/mochitest_support_internal.js:18:3
05:56:44     INFO -      @dom/events/test/pointerevents/mochitest_support_internal.js:10:3
05:56:44     INFO -      EventListener.handleEvent*@dom/events/test/pointerevents/mochitest_support_internal.js:6:1
05:56:44     INFO -  MEMORY STAT | vsize 311MB | vsizeMaxContiguous 445MB | residentFast 154MB | heapAllocated 25MB
05:56:44     INFO -  209 INFO TEST-OK | dom/events/test/pointerevents/test_pointerevent_pointerleave_descendant_over-manual.html | took 874ms
Flags: needinfo?(alessarik)
Attached image test screenshot
OrangeFactor is understated for these because the failures are on Win8 e10s, which basically only runs on Ash (or on Try with e10s forced on).
tracking-e10s: --- → +
Priority: -- → P5
When you wonder WTF, when the bot starts to comment every day saying this failed 50 times the day before, the answer is that https://hg.mozilla.org/integration/mozilla-inbound/rev/a96f09f90b2f5c670a6f7975b4b7045ea68dcd41 reenabled it on Linux.
Assignee: nobody → sshih
(In reply to Phil Ringnalda (:philor) from comment #3)
> When you wonder WTF, when the bot starts to comment every day saying this
> failed 50 times the day before, the answer is that
> https://hg.mozilla.org/integration/mozilla-inbound/rev/
> a96f09f90b2f5c670a6f7975b4b7045ea68dcd41 reenabled it on Linux.

Very sorry for that I didn't notice it will lead intermittent failures. It's my fault. I try to investigate the reason of the intermittent and so far I knew they are caused by an additional mousemove event. I am trying to find where it comes from and the solution to fix them. At the meantime, I will prepare another patch to skip them on Linux and Windows. Please tell me if any concerns or suggestions. Thanks.
Depends on: 1285713
Depends on: 1285128
This bug should be fixed by the patch of bug 1285128. Closed it since [1] shows that it wasn't happened in the past two weeks.

[1] https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1267310&startday=2016-08-01&endday=2016-08-30&tree=all
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(alessarik)
You need to log in before you can comment on or make changes to this bug.