Disable skia font hinting on os x if explicit about grayscale AA (fixes thin fonts in context menus)

RESOLVED FIXED in Firefox 48

Status

()

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

({regression})

44 Branch
mozilla49
Unspecified
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 fixed, firefox49 fixed, relnote-firefox 49+)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

3 years ago
Created attachment 8745031 [details] [diff] [review]
grayscale.patch
Attachment #8745031 - Flags: review?(mstange)
Attachment #8745031 - Flags: review?(mstange) → review+
This patch restores regular font weights to context menus, and it mitigates the flashing of thick-to-thin text that happens if layout toggles the transparency mode of a layer.
Blocks: 1260454
Keywords: regression
Summary: Disable skia font hinting on os x if explicit about grayscale AA → Disable skia font hinting on os x if explicit about grayscale AA (fixes thin fonts in context menus)
status-firefox47: --- → unaffected
status-firefox48: --- → affected
OS: Unspecified → Mac OS X
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1267542

Comment 5

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b6bfaeaa01a6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox49: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48

Updated

3 years ago
Target Milestone: mozilla48 → mozilla49
(Assignee)

Comment 6

3 years ago
Comment on attachment 8745031 [details] [diff] [review]
grayscale.patch

Approval Request Comment
[Feature/regressing bug #]: bug 1260454
[User impact if declined]: Fonts can appear too thin due to grayscale AA.
[Describe test coverage new/current, TreeHerder]: Manual testing
[Risks and why]: Low, this fixes our behavior to what it was before bug 1260454.
[String/UUID change made/needed]: None
Attachment #8745031 - Flags: approval-mozilla-aurora?

Comment 7

3 years ago
Comment on attachment 8745031 [details] [diff] [review]
grayscale.patch

Recent regression, Aurora48+
Attachment #8745031 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 8

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/073d760767b4
status-firefox48: affected → fixed
Release Note Request (optional, but appreciated)
[Why is this notable]:
[Suggested wording]: Resolved a problem on OS X where fonts could appear too thin due to anti-aliasing.
[Links (documentation, blog post, etc)]:
relnote-firefox: --- → ?
49+ for the release note, added "Improved the appearance of OS X fonts"
relnote-firefox: ? → 49+
I don't think we ever shipped the broken version of this. Further, the release note "Improved the appearance of OS X fonts" feels devoid of any useful information.

We should probably just remove this from the 49 release notes.
Flags: needinfo?(mozillamarcia.knous)
(In reply to Jeff Muizelaar [:jrmuizel] from comment #11)
> I don't think we ever shipped the broken version of this. Further, the
> release note "Improved the appearance of OS X fonts" feels devoid of any
> useful information.
> 
> We should probably just remove this from the 49 release notes.

I removed this from the 49 release notes.
Flags: needinfo?(mozillamarcia.knous)
You need to log in before you can comment on or make changes to this bug.