New message invoked from news: URL starts in "Body Text" mode, replies allow undoing <p> insertion

RESOLVED FIXED in Thunderbird 49.0

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rsx11m.pub, Assigned: rsx11m.pub)

Tracking

Trunk
Thunderbird 49.0

Thunderbird Tracking Flags

(thunderbird47 fixed, thunderbird48 fixed, thunderbird49 fixed, thunderbird_esr4546+ fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Part 1:

(Quoting Philip Chee from bug 1265534 comment #4)
> > +    // Look all the possible compose types (nsIMsgComposeParams.idl):
> Where did nsIMsgCompType.NewsPost go?

Part 2:

For nsIMsgCompType.Reply*, the editor's "undo" function isn't disabled, thus Ctrl+Z removes the paragraph and switches to "Body Text" when opening a reply message with "reply above the quote" setting.
(Assignee)

Comment 1

3 years ago
Created attachment 8745116 [details] [diff] [review]
Proposed fix

This fixes these two issues, not addressing any of the other optimizations Phil asked for in the SeaMonkey implementation (bug 1265534 comment #4).
Attachment #8745116 - Flags: review?(mozilla)
(Assignee)

Comment 2

3 years ago
Created attachment 8745117 [details] [diff] [review]
Branch patch

for comm-beta and comm-esr45.
Attachment #8745117 - Flags: review?(mozilla)
(Assignee)

Updated

3 years ago
status-thunderbird47: --- → affected
status-thunderbird48: --- → affected
status-thunderbird49: --- → affected
status-thunderbird_esr45: --- → affected

Comment 3

3 years ago
Comment on attachment 8745116 [details] [diff] [review]
Proposed fix

Review of attachment 8745116 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for cleaning up after the little problems I caused ;-(

(In reply to rsx11m from comment #1)
> This fixes these two issues, not addressing any of the other optimizations
> Phil asked for in the SeaMonkey implementation (bug 1265534 comment #4).
Phil is a great guy, but sometimes he is late with his good ideas, so I've stopped worrying about it too much. I can tolerate a little in-elegant or duplicated code.

I'm approving this for Aurora and Beta straight away. Kent will hate me, but yesterday's Aurora is today's Beta, so I'm extending my authority a little ;-)

I'll land it now. Thanks again.
Attachment #8745116 - Flags: review?(mozilla)
Attachment #8745116 - Flags: review+
Attachment #8745116 - Flags: approval-mozilla-esr45?
Attachment #8745116 - Flags: approval-comm-beta+
Attachment #8745116 - Flags: approval-comm-aurora+

Comment 4

3 years ago
Comment on attachment 8745116 [details] [diff] [review]
Proposed fix

Wrong one ;-)
Attachment #8745116 - Flags: approval-mozilla-esr45?
Attachment #8745116 - Flags: approval-comm-beta+

Updated

3 years ago
Attachment #8745117 - Flags: review?(mozilla)
Attachment #8745117 - Flags: review+
Attachment #8745117 - Flags: approval-comm-esr45?
Attachment #8745117 - Flags: approval-comm-beta+

Comment 5

3 years ago
https://hg.mozilla.org/comm-central/rev/691ad1ad81bc

Aurora (TB 48):
https://hg.mozilla.org/releases/comm-aurora/rev/57fb42dfadae
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-thunderbird48: affected → fixed
status-thunderbird49: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 49.0

Comment 6

3 years ago
Beta (TB 47):
https://hg.mozilla.org/releases/comm-beta/rev/f36d8e57b482

Kent, I pushed this since yesterday's Aurora is today's Beta, so I extended my authority a little.

After the merges yesterday the treeherder looked terrible, so with a fresh push it will look much better ;-)
status-thunderbird47: affected → fixed
This seems to me to be a relatively routine bug. Although I am happy to push this into TB 45 eventually, I see no reason to do an emergency push for TB 45.1 this late in the cycle.

Comment 8

3 years ago
My request was to land this with another unrelated more important issue (bug 1267069), not as an "emergency push" but rather something that gets landed before starting the 45.1b1 build process.

Comment 9

3 years ago
Comment on attachment 8745117 [details] [diff] [review]
Branch patch

[Approval Request Comment]
Regression caused by (bug #): Bug 330891.
Not really a regression, just an incomplete implementation that had overlooked some minor cases.
User impact if declined: Inconsistent behaviour.
Testing completed (on c-c, etc.): Manual testing in Daily where this has landed.
Risk to taking this patch (and alternatives if risky):
Not risky. Two line change adding a missed case and disabling undo during internal manipulation.
Comment on attachment 8745117 [details] [diff] [review]
Branch patch

http://hg.mozilla.org/releases/comm-esr45/rev/e66f1e2e9128
Attachment #8745117 - Flags: approval-comm-esr45? → approval-comm-esr45+

Updated

3 years ago
status-thunderbird_esr45: affected → fixed
tracking-thunderbird_esr45: --- → 46+
You need to log in before you can comment on or make changes to this bug.