crash in cubeb_resampler_speex::cubeb_resampler_speex

RESOLVED FIXED

Status

()

P1
critical
Rank:
12
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: kinetik, Assigned: padenot)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-a8e223bd-7f2f-4159-aee8-5c6582160425.
=============================================================

There's a small number of crashes creating a resampler in the WASAPI backend.  The cause isn't obvious from the crash stacks.

Similar crash with a truncated (probably corrupt) stack: https://crash-stats.mozilla.com/report/index/f1a06780-7795-4b85-b457-d3a6e2160425
Rank: 12
Priority: -- → P1
(Assignee)

Comment 1

3 years ago
Weird, this is with the old resampler code, hasn't really been touched in ages.

The second crash is with the new code, even weirder. Exactly one occurrence each.
(Assignee)

Comment 2

2 years ago
I'm closing this, it's probably some memory trashing or other issue.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.