Today widget - Pressing on the 'New Private Tab' button does not always trigger the requested action on iPad Pro

RESOLVED FIXED in 4.0

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: csuciu, Assigned: jhugman)

Tracking

(Blocks: 1 bug)

unspecified
Other
iOS

Firefox Tracking Flags

(fxios-v4.0 verified, fxios-v5.0 fixed, fxios4.0+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
master 3be0655
iPad Pro 12.9" (iOS 9.3.1)

1. Add Fennec to Today view
2. Tap on 'New Private Tab'

Result: In order to open the new private tab, you'll have to tap multiple times on the button   

I was able to reproduce this issue in the simulator also
(Assignee)

Comment 1

3 years ago
I have reproduced this issue, though haven't been able to deduce the difference between the buttons.
tracking-fxios: ? → 4.0+
(Assignee)

Updated

3 years ago
Assignee: nobody → jhugman
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Created attachment 8746008 [details] [review]
Pull request
Attachment #8746008 - Flags: review?(sleroux)
(Assignee)

Updated

3 years ago
Whiteboard: [needsuplift]
Comment on attachment 8746008 [details] [review]
Pull request

Seems to work fine for me on the simulator but I find the PR description misleading because the only thing you changed was this constraint (https://github.com/mozilla/firefox-ios/pull/1749/files#diff-1212b77cd12723ba0835407b422b084dR123) and disabling userInteractionEnabled on the subview. I'm guessing the userInteractionEnabled is what was the problem?
Attachment #8746008 - Flags: review?(sleroux) → review+
Comment on attachment 8746008 [details] [review]
Pull request

Re-reviewed with the missing commit. Makes sense!
(Assignee)

Comment 5

3 years ago
Merged and closed.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-fxios-v4.0: affected → fixed
status-fxios-v5.0: affected → fixed
Whiteboard: [needsuplift]
Target Milestone: --- → 4.0
(Reporter)

Comment 6

3 years ago
Verifying as fixed on build 4.0.0b7
status-fxios-v4.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.