Turn on by default the cached message compose window

VERIFIED FIXED in mozilla0.9.9

Status

MailNews Core
Composition
P1
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Jean-Francois Ducarroz, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
mozilla0.9.9

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

731 bytes, patch
Bienvenu
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

17 years ago
We have this feature in Mozilla for the last couple months. But is off by
default as we were trying to fix all the related problems found. The only
blocker left is bug 109081 for which we have a fix. We have another fix in bug
73995 which solve the same problem. Once either one of those fixes get checked
in, we can safely set the preference mail.compose.max_recycled_windows to 1 by
default.
(Assignee)

Comment 1

17 years ago
Nominating nsbeta1 as is very important that we turn on this feature in 0.9.9 in
order to have enough test time before 1.0
Whiteboard: nsbeta1, have fix
Target Milestone: --- → mozilla0.9.9
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Depends on: 73995, 109081
(Assignee)

Comment 2

17 years ago
Created attachment 70575 [details] [diff] [review]
Proposed fix, v1
(Assignee)

Updated

17 years ago
Whiteboard: nsbeta1, have fix → nsbeta1, have fix, waiting on bug 73995
(Assignee)

Updated

17 years ago
Priority: -- → P1

Updated

17 years ago
Keywords: nsbeta1+
Whiteboard: nsbeta1, have fix, waiting on bug 73995 → have fix, waiting on bug 73995
Comment on attachment 70575 [details] [diff] [review]
Proposed fix, v1

sr=sspitzer, but wait until the bugs this bug depends on are fixed first
Attachment #70575 - Flags: superreview+

Comment 4

17 years ago
Comment on attachment 70575 [details] [diff] [review]
Proposed fix, v1

r=bienvenu, but I agree with what Seth said.
Attachment #70575 - Flags: review+

Comment 5

17 years ago
Comment on attachment 70575 [details] [diff] [review]
Proposed fix, v1

a=asa (on behalf of drivers) for checkin to the 0.9.9 branch and the 1.0 trunk
Attachment #70575 - Flags: approval+
No longer depends on: 73995
(Assignee)

Comment 6

17 years ago
I've checked in the fix in the branch
Whiteboard: have fix, waiting on bug 73995 → have fix, Fixed in the branch already
(Assignee)

Comment 7

17 years ago
Fixed in the trunk too.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: have fix, Fixed in the branch already
QA Contact: sheelar → stephend
Verified FIXED with:

Mac OS 9.2 - 2002-03-04-12
Mac OS X 10.1.3 - 2002-03-04-03
RedHat 7.2 - 2002-03-04-06
Windows 2K - 2002-03-04-08

I checked mailnews.js for each platform (as well as doing Reply/Reply All) and
verified the performance increase was there (see
http://www.mozilla.org/mailnews/win_performance_results.html for details).

I also checked the migration cases from 4.7x, we add this pref to the mailnews.js.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

17 years ago
I did not realize that this fix get backed out from the branch! It's now back in.

QA, you still have to verify this bug on the branch (starting with tomorrow's build)
re-opening (forgot about branch, sorry).
Status: VERIFIED → REOPENED
Keywords: vbranch
Resolution: FIXED → ---
(Assignee)

Comment 11

17 years ago
reopen for qa verification only...
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
2002-03-06-08-0.9.9 Linux (Debian Woody, 2.4.1.7).

Now, for Mac and Win32.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020306
Netscape6/6.2.1+  (although I notice some problems with the way it works on the
branch, vs. the trunk - these problems are the same problems I experienced with
my linux trunk build from the 4th vs the 5th build (which works fine). 
Specifically, the problems are that it has blue lines in the addressing area and
the window is frozen.  But, the feature is enabled, which is all I think this
bug is addressing.
On to mac...
Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.9) Gecko/20020306 Netscape6/6.2.1+ 

Same thing as above, works, but with issues.

Anyways, this bug is Verified FIXED. (migration was covered, too).
Status: RESOLVED → VERIFIED
(Assignee)

Comment 15

17 years ago
Can you file a bug for the "frozen" blue line...
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.