Location Bar suggest settings are enabled after restart if search suggestions in location bar setting is enabled

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: guhixuz, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160421124000

Steps to reproduce:

1. Enable "Options->Search->Provide search suggestions->Show search suggestions in location bar results" setting.
2. Disable all "Options->Privacy->Location Bar->History/Bookmarks/Open tabs" settings (the bug happens only when all 3 are disabled).
3. Close Firefox and start it again.


Actual results:

Firefox starts and all "Options->Privacy->Location Bar->History/Bookmarks/Open tabs" settings are back to enabled state.


Expected results:

Firefox should remember settings after restart.
(Reporter)

Updated

2 years ago
Component: Untriaged → Preferences
(Reporter)

Comment 1

2 years ago
This seems to be related to how settings are saved in the "prefs" file. When all the "Location Bar" suggestions are disabled, there's no settings written in the prefs file (i.e. the settings are removed from the file if disabled). And it seems that when all 3 of them are not in the prefs file, then Firefox for some reason thinks that they should be turned on. Suggested fix: write the settings to the prefs file even if they are disabled.
(Reporter)

Updated

2 years ago
Has STR: --- → yes

Comment 2

2 years ago
It's fixed in 49.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bae525a694e2dc0aa433885be8751330d4995a49&tochange=fd8bdef8ef752875c509141b3345ab9e722d6cec

Marco Bonardo — Bug 1223728 - Remove the unifiedcomplete pref, the urlinline component and stop bundling the old autocomplete component in Firefox. r=adw
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Depends on: 1223728
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

2 years ago
I can't find Firefox 49 download to test if it's fixed.

How do you know it's fixed?

Comment 4

2 years ago
49 is on Nightly channel at the moment, you can download Nightly here: https://nightly.mozilla.org/
(Reporter)

Comment 5

2 years ago
I can confirm, fixed in 49.0a1.

Though it's about 4 months(!) until that lands stable. :(

Comment 6

2 years ago
In general, some bugfixes are backported to Aurora and sometimes Beta. I'm not sure about this one, because the underlying bug affects the working of the awesome bar.
You need to log in before you can comment on or make changes to this bug.