Closed Bug 1267884 Opened 3 years ago Closed 3 years ago

Update support libraries to 23.4

Categories

(Firefox for Android :: General, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 52
Iteration:
1.6
Tracking Status
firefox52 --- fixed

People

(Reporter: liuche, Assigned: ahunt)

References

(Blocks 1 open bug)

Details

(Whiteboard: [MobileAS])

Attachments

(4 files, 4 obsolete files)

The 23.2.1 recyclerview compat library fixes a bug where wrap_content didn't work, and recyclerview expands to fill the whole space. We need this for our new empty view for the Combined History home panel, so that we can have the empty view displayed underneath the recycler view.

Note to self, this requires:
* Update dependency in build.gradle
* Build artifact with a gradle-dependencies try push
* Push new artifact changes to tooltool and update the in-tree manifests

https://gecko.readthedocs.org/en/latest/build/buildsystem/toolchains.html#firefox-for-android-with-gradle
Er, I guess it was not a bug, just a new feature:
http://android-developers.blogspot.com/2016/02/android-support-library-232.html
We should update all support libraries to 23.2.1. They all need to be in sync to work properly. After that we should do some testing, I saw a bunch of support library bug reports and it looked like you are trading bugfixes against new bugs with every update currently. :)

I'm just updating Gradle and the gradle plugin as part of bug 1263390. To do so I need to touch all the same parts (build.gradle, tooltool, ...). I could update the support libraries as part of bug 1263390 too.
I just saw that there is already version 23.3 out. I'm having so much fun updating the builder that I'll take this too.. ;)
Assignee: nobody → s.kaspari
Status: NEW → ASSIGNED
Summary: Update recyclerview compat library from 23.0.1 to 23.2.1 → Update support libraries to 23.3
This adds the new libraries and builds locally and on the builders.

However our settings activity is crashing because we somehow reference VectorDrawableCompat which has been removed.
appcompat has new dependencies: support-vector-drawable and animated-vector-drawable. I tried to add them but this crash is still there. Either I did something wrong or those libraries are somewhat special. It's also notable that this crash only happens when building with 'mach'. Gradle builds just work.
Leaving this for a rainy day..
Assignee: s.kaspari → nobody
Status: ASSIGNED → NEW
23.4 has been released yesterday.
Summary: Update support libraries to 23.3 → Update support libraries to 23.4
I've started looking into this. The "Add new support library dependencies: support-vector-drawable, animated-vector-drawable." patch seems to be enough for my mach builds to not crash in the settings activity (after clobbering).

We'll need to reduce our method count slightly for this to be able to land, I'm looking into that in Bug 1306104 right now.
Assignee: nobody → ahunt
Status: NEW → ASSIGNED
Depends on: 1306104
Whiteboard: [MobileAS]
Priority: -- → P1
Priority: P1 → P2
Attachment #8796603 - Flags: review?(liuche) → review?(s.kaspari)
Attachment #8751339 - Attachment is obsolete: true
Attachment #8751340 - Attachment is obsolete: true
Attachment #8751341 - Attachment is obsolete: true
Attachment #8751369 - Attachment is obsolete: true
Comment on attachment 8796601 [details]
Bug 1267884 - Upgrade support libraries to 23.4

https://reviewboard.mozilla.org/r/82404/#review81038
Attachment #8796601 - Flags: review?(s.kaspari) → review+
Comment on attachment 8796602 [details]
Bug 1267884 - Add empty updateVisuals() to GeckoCustomTabsService to match customtabs-23.4

https://reviewboard.mozilla.org/r/82406/#review81040
Attachment #8796602 - Flags: review?(s.kaspari) → review+
Comment on attachment 8796603 [details]
Bug 1267884 - Touch CLOBBER file.

https://reviewboard.mozilla.org/r/82408/#review81042
Attachment #8796603 - Flags: review?(s.kaspari) → review+
Sorry for the priority spamming, I thought this wouldn't be ready today - but it looks like it will make it after all.
Priority: P2 → P1
Pushed by ahunt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/25e1ca942799
Upgrade support libraries to 23.4 r=sebastian
https://hg.mozilla.org/integration/autoland/rev/abc52d4c5f87
Add empty updateVisuals() to GeckoCustomTabsService to match customtabs-23.4 r=sebastian
https://hg.mozilla.org/integration/autoland/rev/cc4bdd6afea0
Touch CLOBBER file. r=sebastian
Backout by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/537a4ce2ecb3
Backed out changesets cc4bdd6afea0, abc52d4c5f87, and 25e1ca942799 for Android bustage
Comment on attachment 8797181 [details]
Bug 1267884 - Update TestColorProcessor to reflect update palette library colour extraction

https://reviewboard.mozilla.org/r/82774/#review81706

::: mobile/android/tests/background/junit4/src/org/mozilla/gecko/icons/processing/TestColorProcessor.java:36
(Diff revision 1)
>  
>          final Processor processor = new ColorProcessor();
>          processor.process(null, response);
>  
>          Assert.assertTrue(response.hasColor());
> -        Assert.assertEquals(0xFFF80000, response.getColor());
> +        Assert.assertEquals(0xFFFF0000, response.getColor());

nit: Maybe use Color.RED like we use below to generate the image.
Attachment #8797181 - Flags: review?(s.kaspari) → review+
Pushed by ahunt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6ac1eb24f8ab
Upgrade support libraries to 23.4 r=sebastian
https://hg.mozilla.org/integration/autoland/rev/982c7d7ce6f0
Add empty updateVisuals() to GeckoCustomTabsService to match customtabs-23.4 r=sebastian
https://hg.mozilla.org/integration/autoland/rev/37bb8e6b60e2
Touch CLOBBER file. r=sebastian
https://hg.mozilla.org/integration/autoland/rev/579fbfb0801a
Update TestColorProcessor to reflect update palette library colour extraction r=sebastian
Depends on: 1308390
This has increased the classes.dex size by 230kB, I assume there is nothing we can do to reduce this?
Iteration: --- → 1.6
You need to log in before you can comment on or make changes to this bug.