Bugzilla new bug submit does nothing

VERIFIED WORKSFORME

Status

()

P1
blocker
VERIFIED WORKSFORME
19 years ago
2 years ago

People

(Reporter: mcafee, Assigned: akkzilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Linux, apprunner.
I type all this stuff in for a new bug
and hit submit, the page just sits there
and does nothing.!

Updated

19 years ago
Assignee: karnaze → kmcclusk

Comment 1

19 years ago
Reassigning to Kevin.

Updated

19 years ago
QA Contact: cpratt
Summary: Bugzilla new bug submit does nothing

Comment 2

19 years ago
testing to see if an update works... I do notice that the summary field, QA
contact etc. show up blank

Updated

19 years ago
QA Contact: cpratt
Summary: Bugzilla new bug submit does nothing

Comment 3

19 years ago
Nice, it blanked out the summary and QA contact, but at least I could update it.
Looks like our builds are from 7am. When did you pull.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: kmcclusk → pollmann
Status: ASSIGNED → NEW
Eric, reassigning to you. Please check the post data from mozilla against the
post data generated from communicator. If different, reassign back to me.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 5

19 years ago
Blanking out of the summary and QA contact is bug 12475.

Comment 6

19 years ago
What happens when you click Submit?  Does the entire AppRunner application
freeze, or is it still responsive and just not submitting forms?  I was able to
reproduce a complete freeze just now...

Updated

19 years ago
Assignee: pollmann → buster
Status: ASSIGNED → NEW

Comment 7

19 years ago
I reproduced this by:
1) Go to bugzilla
2) Enter new bug report
3) Browser
4) Assign to pollmann@netscape.com
5) Summary=test
6) Commit

It's infinite looping in nsHTMLToTXTSinkStream::WriteWrapped()
I noticed mWrapColumn is 0, which seems to be causing the infinite loop.

This is happening when the GFX Text frames are trying to get their text to
submit the form.

This is the stack up to relevant point:
nsHTMLToTXTSinkStream::WriteWrapped
nsHTMLToTXTSinkStream::AddLeaf
nsXIFDTD::AddLeaf
nsXIFDTD::HandleTextToken
XIFDispatchTokenHandler
CTokenHandler::operator()
nsXIFDTD::HandleToken
nsXIFDTD::BuildModel
nsParser::BuildModel
nsParser::ResumeParse
nsParser::Parse
nsTextEncoder::EncodeToString
nsHTMLEditor::OutputToString
nsGfxTextControlFrame::GetTextControlFrameState
nsGfxTextControlFrame::GetProperty
nsHTMLTextAreaElement::GetValue
nsGfxTextControlFrame::GetText
nsGfxTextControlFrame::GetNamesValues
nsFormFrame::ProcessAsURLEncoded
nsFormFrame::OnSubmit

Updated

19 years ago
Assignee: buster → akkana

Comment 8

19 years ago
akkana:  looks like you're on top of the stack. If I'm somehow misusing the
wrapping API, let me know and I'll fix my code.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M10
(Assignee)

Comment 9

19 years ago
I'll take a look.  Even if you are somehow using the API in an unusual way, if
that somehow causes an infinite loop then that's a bug that needs fixing.
(Assignee)

Updated

19 years ago
Depends on: 12808
(Assignee)

Comment 10

19 years ago
I can't reproduce or work on this on Linux, because clicking in any gfx-rendered
text field produces an immediate crash in nsBlockFrame::HandleEvent.

I've filed bug 12808 on that issue, and will meanwhile be looking over the code
to see if I can see possible infinite loops just by inspection, and I'll update
my tree on Windows in the meantime and see if I can reproduce it there.
(Reporter)

Updated

19 years ago
Severity: normal → blocker
Priority: P3 → P1
(Reporter)

Comment 11

19 years ago
Another test: go to http://bugzilla.mozilla.org/,
type in a bug number, hit find.  Nothing happens.
(Reporter)

Comment 12

19 years ago
submit is still broken for non-gfx widget mode as well.

Comment 13

19 years ago
Is this Linux only?
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 14

19 years ago
This seems to be working now, for gfx widgets.  Not sure about non-gfx widgets,
but that would be a different bug in any case.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
Trusting akkana and verifying.
You need to log in before you can comment on or make changes to this bug.