If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

In new version Firefox (46.0) don't rendered point cloud model in potree renderer

RESOLVED DUPLICATE of bug 1268096

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 1268096
a year ago
a year ago

People

(Reporter: spatial.hast, Unassigned)

Tracking

({regression})

46 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox46 wontfix, firefox-esr38 unaffected, firefox-esr45 unaffected)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.87 Safari/537.36

Steps to reproduce:

I open demos http://potree.org/demo/potree_1.3/showcase/lion_head_simone_garagnani.html and http://potree.org/demo/potree_1.3/showcase/eclepens.html in Firefox 46.0 (or Firefox Nightly 49.0a1)


Actual results:

Point clouds doesn't render in potree renderer for new release Firefox, but available in previous release (I used Firefox 45.0)


Expected results:

In potree renderer should be displayed point cloud data.
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Comment 1

a year ago
Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f143af51f6e35932927b8ccac2509facbbe7b539&tochange=66fb852962c0d5f6f5fe0604204da4f5d17763c9

Probably due to the release of WebGL 2 in bug 1232864.
Component: Untriaged → Canvas: WebGL
Keywords: regression
Product: Firefox → Core

Comment 2

a year ago
Error console:

Error: WebGL: texImage2D: Uploading ArrayBuffers with FLIP_Y or PREMULTIPLY_ALPHA is slow. three.js:23351:5
THREE.WebGLProgram: gl.getProgramInfoLog()C:\fakepath(83,10-87): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them

 three.js:34:27
Error: WebGL: texImage2D: Uploading ArrayBuffers with FLIP_Y or PREMULTIPLY_ALPHA is slow. three.js:23351:5

Comment 3

a year ago
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1101f5bec98449a2c033c0f8df80b2d8885870d5&tochange=f982d05e0cde64865fe11e1e0f4c6799497ff437

Regressed by: 
	f982d05e0cde	Jeff Muizelaar — Bug 1232902. Update ANGLE to chromium/2592
Blocks: 1232902
Status: UNCONFIRMED → NEW
status-firefox46: --- → wontfix
status-firefox47: --- → affected
status-firefox48: --- → affected
status-firefox49: --- → affected
status-firefox-esr38: --- → unaffected
status-firefox-esr45: --- → unaffected
Ever confirmed: true

Comment 4

a year ago
FWIW, Setting webgl.angle.try-d3d11 = false fixes im my PC.
Does this work in Chrome?
Flags: needinfo?(jmuizelaar)

Comment 6

a year ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> Does this work in Chrome?

It works on Google Chrome dev 51
(Reporter)

Comment 7

a year ago
After changing about:config browser settings:
  webgl.force-enabled=true.
  webgl.msaa-force=true.
  layers.acceleration.force-enabled=true.
  gfx.direct2d.force-enabled=true.
point cloud are available in potree renderer for Firefox 46.0 and Firefox Nightly 49.0a1.
https://github.com/potree/potree/issues/226
This is probably a dup of bug 1268096
Flags: needinfo?(jmuizelaar)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1268096
status-firefox47: affected → ---
status-firefox48: affected → ---
status-firefox49: affected → ---
You need to log in before you can comment on or make changes to this bug.