If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

full-screen mode in new window displays title bar of background application's window

VERIFIED WORKSFORME

Status

()

Core
XUL
VERIFIED WORKSFORME
16 years ago
4 years ago

People

(Reporter: Pete Boyd, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020220
BuildID:    2002022003

a second browser window opened in full-screen mode has the title bar of an
application running in the background remaining visible above Mozilla's title bar

Reproducible: Always
Steps to Reproduce:
1. either in Classic or Modern skin, with an existing window in full-screen
mode, create a new window (not tab)
2. put that window into full-screen mode

Actual Results:  an impression of the title bar of the window that was behind
the browser window remains above the uppermost Mozilla bar, even if that prior
applciations' window wasn't maximised. the minimise, restore and close buttons
of the background application are inoperable

Expected Results:  full-screen mode should be full screen, rather than showing
another applications' title bar aswell

if the first window is not in full-screen mode when the second window is
created, everything works fine.

Comment 1

16 years ago
-> hewitt
Assignee: jaggernaut → hewitt

Comment 2

16 years ago
Is this because the second window is already sized to the screen when it's
created (that being a separately reported bug), thus confusing the hell out of
Mozilla?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
What happens is that when Mozilla enters full-screen mode it turns off the OS
chrome and resizes the window. However in the case that the window was already
the exact screen size this fails to reset the window styles, resulting in the
odd behaviour described. You need to call SetWindowPos with the SWP_FRAMECHANGED
flag to fix this.
Assignee: hewitt → nobody
QA Contact: jrgmorrison → xptoolkit.widgets

Comment 4

7 years ago
I don't think this bug is still valid.

For what is worth is WFM using Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100716 Minefield/4.0b2pre.
(In reply to RNicoletto from comment #4)
> I don't think this bug is still valid.
> 
> For what is worth is WFM using Mozilla/5.0 (Windows; Windows NT 5.1; en-US;
> rv:2.0b2pre) Gecko/20100716 Minefield/4.0b2pre.

agree
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.