Intermittent browser_addons_debug_bootstrapped.js | This test exceeded the timeout threshold. It should be rewritten or split up.

RESOLVED FIXED in Firefox 49

Status

P2
normal
RESOLVED FIXED
3 years ago
9 months ago

People

(Reporter: KWierso, Assigned: jdescottes)

Tracking

({intermittent-failure})

49 Branch
Firefox 50
intermittent-failure

Firefox Tracking Flags

(firefox49 fixed, firefox50 fixed)

Details

Attachments

(1 attachment)

Priority: -- → P3
Priority: P3 → P2
See Also: → bug 1278111
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
(Assignee)

Updated

3 years ago
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Julian, this intermittent may just be needing a requestLongerTimeout() call.

It seems to fail during test shutdown and may just be long to finish:

 23:46:47     INFO -  17 INFO TEST-PASS | devtools/client/aboutdebugging/test/browser_addons_debug_bootstrapped.js | After uninstall, the addon name disappears from the list of addons: Firefox Hello,FlyWeb,IndexedDBTest,Mochitest,mozscreenshots,Multi-process staged rollout,Pocket,Special Powers,Web Compat,WorkerTestBootstrap -
 23:46:47     INFO -  18 INFO Closing about:debugging
 23:46:47     INFO -  19 INFO Removing tab.
 23:46:47     INFO -  20 INFO Waiting for event: 'TabClose' on [object XULElement].
 23:46:47     INFO -  21 INFO Got event: 'TabClose' on [object XULElement].
 23:46:47     INFO -  22 INFO Tab removed and finished closing
 23:46:47     INFO -  23 INFO Leaving test bound
 23:46:47     INFO -  24 INFO TEST-UNEXPECTED-FAIL | devtools/client/aboutdebugging/test/browser_addons_debug_bootstrapped.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort.
(Assignee)

Comment 13

3 years ago
(In reply to Alexandre Poirot [:ochameau] from comment #12)
> Julian, this intermittent may just be needing a requestLongerTimeout() call.
> 
> It seems to fail during test shutdown and may just be long to finish:
> 
>  23:46:47     INFO -  17 INFO TEST-PASS |
> devtools/client/aboutdebugging/test/browser_addons_debug_bootstrapped.js |
> After uninstall, the addon name disappears from the list of addons: Firefox
> Hello,FlyWeb,IndexedDBTest,Mochitest,mozscreenshots,Multi-process staged
> rollout,Pocket,Special Powers,Web Compat,WorkerTestBootstrap -
>  23:46:47     INFO -  18 INFO Closing about:debugging
>  23:46:47     INFO -  19 INFO Removing tab.
>  23:46:47     INFO -  20 INFO Waiting for event: 'TabClose' on [object
> XULElement].
>  23:46:47     INFO -  21 INFO Got event: 'TabClose' on [object XULElement].
>  23:46:47     INFO -  22 INFO Tab removed and finished closing
>  23:46:47     INFO -  23 INFO Leaving test bound
>  23:46:47     INFO -  24 INFO TEST-UNEXPECTED-FAIL |
> devtools/client/aboutdebugging/test/browser_addons_debug_bootstrapped.js |
> This test exceeded the timeout threshold. It should be rewritten or split
> up. If that's not possible, use requestLongerTimeout(N), but only as a last
> resort.

That was my guess as well but I wanted to get some metrics before just adding a longer timeout.

I added timings to a try run here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e3459fced2c2&selectedJob=23564307
Turns out, it takes almost 30 seconds to perform "yield onCustomMessage;" after clicking on the debug button. Looks like we wait on "a notification sent by a script evaluated the test addon via the web console".

I don't think there's much we can do here to speed up this process, so I think it is ok to simply wait longer.
(Assignee)

Comment 14

3 years ago
Created attachment 8770505 [details]
Bug 1268178 - fix browser_addons_debug_bootstrapped.js intermittent;

Review commit: https://reviewboard.mozilla.org/r/63916/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/63916/
Attachment #8770505 - Flags: review?(poirot.alex)
Comment on attachment 8770505 [details]
Bug 1268178 - fix browser_addons_debug_bootstrapped.js intermittent;

https://reviewboard.mozilla.org/r/63916/#review60982

I imagine there is most likely many ways to optimise runtime speed of browser toolbox opening, but that sounds like a significant work.
Recently I fixed "debugger would run" exception which significantly slow down things, there may be some left?

But in the meantime, better make this test non-intermittent.
Attachment #8770505 - Flags: review?(poirot.alex) → review+

Comment 17

3 years ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/b8b27cb2e148
fix browser_addons_debug_bootstrapped.js intermittent;r=ochameau

Comment 18

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b8b27cb2e148
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Comment hidden (Intermittent Failures Robot)

Comment 20

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/550f70e6855f
status-firefox49: affected → fixed
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1278111

Updated

9 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.