Addressbook not working correctly

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: ralf_haerter, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:AddressbookTab])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160421124000

Steps to reproduce:

I upgraded my previous TB-Installation (since ever) after I got the massage, that a new TB Version is available.


Actual results:

At the first glance everything seems to work fine (under Win10-64bit), but after using the addressbook that stops. (* I use at least a dozen of address books. *)

In some cases the contacts show up as expected, but mostly just the list of contacts appear and the 'details window' (bottom right corner) was empty.

On rare occasions ... after clicking one contact after another ... there was a contact, wich shows the full details in the bottom right window (as expected) AND after(!) that all other contacts in the same address book, showed their details too.

After stopping / restarting TB the same error occurs, in the same address books AND the same behaviour after finding a contact that shows the full information.

So the error could be reproduced.

I'm using some extensions with TB:
- Address Book Tab
- Edit HTML
- ImportExportTools
- Lightning
- LookOut
- Manually Sort Folders
- MoreFunctionsForAddressBook
- MyPhoneExplorer
- Select Addressbook Text

For now I downgraded TB to version 38.7.2 and everything went to normal. (* I didn't test version 45 under OSX and Linux (Mint 64bit), but when I do, I'll post my findings.


Expected results:

What should have happened? ... I expected that TB acts in a familiar way, if it comes to Contacts / Address Book.

Excuse me for my errors in us-engl., it's not my 'native tongue'. (* I'm german ... we didn't have it with the "...ly". :-D *)
Have you tried running in safe mode? (Help -> Restart With Add-ons Disabled)

It's very likely that one of your add-ons is causing an issue.

Updated

3 years ago
Flags: needinfo?(ralf_haerter)
Whiteboard: [addon:??]

Comment 2

3 years ago
We know MoreFunctionsforAddressBook causes this, see bug 1268600.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ralf_haerter)
Resolution: --- → INVALID
Whiteboard: [addon:??] → [addon:MoreFunctionsforAddressBook]
(Reporter)

Comment 3

3 years ago
(In reply to Jorg K (GMT+2) from comment #2)
> We know MoreFunctionsforAddressBook causes this, see bug 1268600.

Thank you. I'll try the new TB Version without MoreFunctionsforAddressBook.
(Reporter)

Comment 4

3 years ago
(In reply to Jorg K (GMT+2) from comment #2)
> We know MoreFunctionsforAddressBook causes this, see bug 1268600.

In this case it was the "AddressbookTab" Add-on.

Comment 5

3 years ago
Thanks for letting us know.
Summary: Addressbook → Addressbook not working correctly
Whiteboard: [addon:MoreFunctionsforAddressBook] → [addon:AddressbookTab]
You need to log in before you can comment on or make changes to this bug.