Closed Bug 1268286 Opened 5 years ago Closed 5 years ago

Suggestions appear shifted if user has at least 1 button before urlbar or notification on site

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox49 --- affected

People

(Reporter: arni2033, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160409030219
STR:
1. Move Bookmarks, Homepage and History buttons before urlbar in navigation toolbar
2. Open http://www.kgoradio.com/ , type "Hello world" in urlbar

AR:  Urlbar suggestions appear far away from the string user types in urlbar
ER:  Urlbar suggestions should be directly under typed string

Note:
 With this brand new design, user has to constantly concentrate on different parts of the screen
 Actually, all brand new stuff is broken, unreasoned and has significantly increased the time
 required for common operations. Take GoogleChrome's example: they only allow to configure 1 button
 before urlbar, and still they handled that case correctly.
 
This is regression from bug 1181078. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=c131636dae420773342d1439b6086b6c62b222f4&tochange=061165ac1ff9e076ec51ea268878efa751173511
That's by design: we align the text when there are at most two toolbar buttons before the urlbar, not counting the back and forward buttons.  After that we stop aligning.  So Firefox handles the one-button-before case "correctly" too.  See bug 1262588.
No longer blocks: 1181078
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
See Also: → 1262588
It makes it look so much worse, and so much harder to read, though.. 

I even had some time to adjust now, and while I can deal with it now, the old way was still much more faster to read, and looked way better.
Thank you for your report. As Drew explained we made a choice to not go over a certain threshold, your case is rarer than what you may think, most users don't keep that many buttons to the left of the locationbar (indeed most don't have any), and if we'd allow any amount of left padding, the awesomebar contents would shrink too much and look even worse. So we decided for the 2 buttons compromise.
I hope you can try to find a new setup with your 2 most used button on the left and the rest on the right.
Resolution: INVALID → WONTFIX
(In reply to Marco Bonardo [::mak] from comment #3)
> As Drew explained we made a choice to not go over a certain threshold
When I last checked it on Nightly (ID 20160409030219), this feature didn't work at_all. So I just took the most obvious screenshot to demonstrate it. Before reporting I only checked the same case, and thought that things are still at their old state, but as you said, it's now working good.
I rarely use 3 buttons before urlbar myself - usually when I test something with zoom level. There's no such thing as my "usual" setup though, because it changes quite often.
> if we'd allow any amount of left padding, the awesomebar contents would shrink too much
Yes, that was obvious, but it could be solved by padding limitation. E.g. "if there're more than 2 buttons, set padding = width of first 2 buttons + width of stuff in urlbar, to reduce the shift".
(In reply to Marco Bonardo [::mak] from comment #3)
> and if we'd allow any amount of left padding, the awesomebar contents would shrink too much
> and look even worse. So we decided for the 2 buttons compromise.

Mh, I see, thanks for explaining.. 

I am curious, though. 
I use an UHD screen on my laptop, and my desktop uses a 2560x1440 monitor, so for me that wouldn't be an issue. I was just wondering if it could perhaps adjust the amount of padding allowed based on the window size of Firefox? Might be a rare case, too, I don't know the statistics. 

Guessing this can be solved for people like me with addons, if the above suggestion is not worth the effort for the amount of users that would benefit from it?

Sorry for bringing it up again!
sorry, we try to do our best, but it's clearly hard to satisfy everyone. The point of not doing very specific fixes for just few users is that anyone has his own preferences clearly, and if we'd end up trying to satisfy all of them, shortly the browser would become an unmaintainable pile of options.
So we usually look for compromises that cover the majority of cases.
Even if we'd consider the screen size, having a too wide empty space on the left would still look exotic/bad.
Fwiw, I'm also planning to buy a 21:9 monitor this year, so I sympathize with your case, but it's still not very common.
You need to log in before you can comment on or make changes to this bug.