Closed Bug 12683 Opened 21 years ago Closed 21 years ago

onchange events in dropdown boxes not occurring properly

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: bgiles, Assigned: pollmann)

References

()

Details

Nike.com's navigation (which I built) relies on the javascript onchange event to move users about the site (there's servlet to run the navigation if javascript is turned off).  The current behavior is such that when the value in the dropdown box changes, nothing happens instead of the browser being sent to a new page by a change in the location.href value.  The browser only notices the change only if focus is brought back to the dropdown box a second time.

PS. if this bug gets fixed or noticed, could you point me to where in the code I might be able to make changes to stuff like this?

Beau Giles
Red Sky Interactive
San Francisco, Ca
Assignee: mccabe → vidur
Component: Javascript Engine → DOM Level 0
Reassigning to the DOM level 0 component.

(Beau - you might try an lxr (http://lxr.mozilla.org) search for onChange or
OnChange.)
Assignee: vidur → joki
Component: DOM Level 0 → Event Handling
QA Contact: cbegle → janc
i think this is a dupe of http://bugzilla.mozilla.org/show_bug.cgi?id=8915 but
janc can verify.

beau, for your future reference:

http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser for
determining what the right component is.

http://www.mozilla.org/quality/bug-writing-guidelines.html for info on writing
a good and useful bug report.
Assignee: joki → pollmann
Pollmann, you want to make the final call, dupe or not?
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
In fact, this bug is now be fixed, as GFX Selects are the default.  I tested
with todays build and it works as expected.

The only platform/preference combination that doesn't work is Windows/Native
widgets.
Status: RESOLVED → VERIFIED
verified
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.