Getting screen size in content process costs an additional sync IPC

RESOLVED DUPLICATE of bug 1194751

Status

()

defect
RESOLVED DUPLICATE of bug 1194751
3 years ago
4 months ago

People

(Reporter: xidorn, Unassigned)

Tracking

(Blocks 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: btpp-fixlater)

For avoid potential additional resize reflow, we change the window dimensions to the screen dimensions in advance for fullscreen change in the content process.

Currently, we get the size of the screen in the content process, which costs an additional IPC call, which could be avoided if we pass the screen together with the fullscreen change message itself.

It isn't too expensive, but it's still worth several tens of ms we may want to avoid.
It's worth 10% of the time.
tens of ms? huh, parent process must be busy doing something else if it is that slow to reply.
The parent process could be reflowing the UI.
(In reply to Olli Pettay [:smaug] from comment #2)
> tens of ms? huh, parent process must be busy doing something else if it is
> that slow to reply.

We often have several CPU cores decoding video while transitioning to full screen.
I'm guessing this is something we/Xidorn aim to fix in the next few months => "fixlater".
Whiteboard: btpp-fixlater
Blocks: SyncIPC
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194751
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.