message contents disappear after deleting an imap folder



Folder and Message Lists
2 years ago
a year ago


(Reporter: Lucien Gentis, Unassigned)


45 Branch

Firefox Tracking Flags

(Not tracked)



(1 attachment)



2 years ago
Created attachment 8746455 [details]
shows TEST folder after deleting another folder

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

Steps to reproduce:

In left part (mailboxes and folders) : my mailbox contains different folders ; I delete one of these folders, and then select another one

Actual results:

message listing of this another folder is displayed correctly, but content of each message is empty (no header, no body).
This doesn't happen each time, but circa one time for two
I have to restart Thunderbird in order to see message contents again.

Expected results:

When I select a message in the list, I should see its content in frame below

Comment 1

2 years ago
Tried reproducing the bug. 

Thunderbird 45.1 with Lightning 4.7 and Quicktext enabled, without safe mode.

Created a new folder, copied a few messages to the new folder. Deleted the new folder. Selected another folder. Message listing of the selected folder is displayed correctly and the content of each message is fine. 

I have never faced this problem before.

Comment 2

2 years ago
First, thanks for your comment.

I tried to reproduce what you did.

In fact, in order to reproduce the problem, the new folder you create must be directly at the root of your mailbox ; it must not be a subfolder of another one.
I tried to delete a subfolder, and the the content of messages remains visible.

(I updated Thunderbird to 45.1.0 version, and problem is still here)

Comment 3

2 years ago
I found the reason why this problem occurs, but no explanation:

In Tools -> Account Settings -> Server Settings:
For "When I delete a message", I had "Put in folder Trash" (I translate from french)
If I set it to "Remove it immediately.", problem is solved !

Comment 4

2 years ago
Thanks for getting back.
So are you still facing the problem ?

Comment 5

2 years ago
I am still facing the problem.

Additional infos:
- I have 2 mailboxes configured in my thunderbird profile, each with a different ISP, and the problem is present in the two mailboxes.
- Problem is also present with a different user session (with the same mailboxes) under Windows 7 on the same machine.
- Problem is also present under Linux - Ubuntu via VirtualBox (with the same mailboxes) on the same machine
- Other users on other machines don't seem to encounter this problem.

So, I must still investigate with other users if some of them encounter this problem ; also, I'll try to reproduce it on my personal machine at home with same mailboxes.

I'll come back to tell about the result of my investigations.

Comment 6

2 years ago
OK, no need to wait till this evening when I'm at home.

I can confirm that other users have the same problem : the one who didn't have it had 24.3.0. version of Thunderbird installed, and the problem is not present with this version.

I made tests on another machine with 38.8.0 and 45.1.0 versions and the problem is the same.

I remind the steps to reproduce the problem :

- Create a new folder at the root of the mailbox (at the same level as Draft, Sent or Trash)
- Slide with mice a message from another folder into the new created folder
- Go to the new created folder
- Select the message you just slided in the new created folder : its content must appear at the bottom of the Thunderbird window
- Right click on the new created folder and select Delete
- Confirm Deletion

At this time, there's already a problem: the folder is deleted, there no more message at the top of the Thunderbird window, but the message content remains at the bottom.

Finally, it's impossible to display the content of any message in any folder until you restart Thunderbird.

Comment 7

2 years ago
Thanks for your investigations.
I was able to reproduce the bug.

Comment 8

a year ago
So the bug is still present with 45.4.0 version.
You need to log in before you can comment on or make changes to this bug.