bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Teach |mach try| to re-use builds from other pushes

RESOLVED DUPLICATE of bug 1240644

Status

Testing
General
P2
normal
RESOLVED DUPLICATE of bug 1240644
2 years ago
2 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reuse-builds])

(Reporter)

Description

2 years ago
It would be great to iterate on an existing build on try and only make test changes.
I'm going to track this under the awesome try tracking bug, however, this is more easily implemented after we change to a checkout model for testing (bug 1234728).

We can teach |mach try| wish revision to continue from and we can modify the TaskCluster graph to include Buildbot jobs (mozci can do this for us without .yml files).

> On Tue, Apr 26, 2016 at 03:49:11PM +0200, Gabor Krizsanits wrote:
>> As someone who was high on the list of try server usage for two
>> weeks....  My problem was a test I tried to fix for both e10s and
>> non-e10s, and it timed out _sometimes_ on _some_ platforms even
>> depending on debug/release build. It was a whack-a-mole game by
>> fiddling with the test and a complex patch. I did stop old builds but
>> I did not run only the test in question but the rest of them as well
>> because of the invasive nature of the patch the whole thing was
>> sitting on. Probably I could have been smarter, BUT...
>>
>> What would have helped me a lot in this case and most cases when I
>> rely on the try server is the ability to push a new changeset on top
>> of my previous one, and tell the server to use the previous session
>> instead of a full rebuild (if there is only a change in the tests
>> that's even better, no rebuild at all) and then tell the server
>> exactly which tests I want to re-run with those changes (as it can be
>> an empty set this can be used to trigger additional tests for a
>> previous push). This could all be done by an extensions to the try
>> syntax like -continue [hash]. As an addition this follow up push would
>> also kill the previous job.
>>
>> Maybe there is already such functionality available, just I'm not
>> aware of it (I would be so happy if this were the case, and would feel
>> bad for the machine hours I wasted...), if so please let me know.
(Reporter)

Comment 1

2 years ago
Removing dependency on bug 1234728 (Switch to a source checkout model) since it is not a hard requirement.
No longer depends on: 1234728
(Reporter)

Comment 2

2 years ago
Another approach would be to let the gecko decision task take care of it (instead of |mach try|).
(Reporter)

Updated

2 years ago
Blocks: 1278680
No longer blocks: 1261944
(Reporter)

Updated

2 years ago
Whiteboard: [skip-builds]
(Reporter)

Updated

2 years ago
Whiteboard: [skip-builds] → [reuse-builds]
(Reporter)

Comment 3

2 years ago
We're not going to tackle this on Q3.
Priority: -- → P2
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1240644
You need to log in before you can comment on or make changes to this bug.