Composer adds <base href="file:///

VERIFIED DUPLICATE of bug 122227

Status

--
trivial
VERIFIED DUPLICATE of bug 122227
17 years ago
14 years ago

People

(Reporter: spam, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Testing with a current CVS build, Linux:

I have a little webpage called My_Mozilla_FAQ.html and i upload it via ftp to a
website now and then. This is part of that page usually:

<base href="My_Mozilla_FAQ.html"></head>

When i now save the page in composer, that line is modified into this:

<base href="file:///home/dark2/RECOVER/dark/pix/My_Mozilla_FAQ.html"></head>

Which you might guess is where the file is stored on my local disk.
Links and images elsewhere on the page are left as is - they are not broken with
filepaths anymore, like they were in bug 121980.

I can't see any good reason why Composer should tell "the world" about my PC's
internal file structures. So I think the full local file-path in the "base href"
is a bug.

Comment 1

17 years ago
Is this also due to nsWebBrowserPersist problems?  Cc'ing others.

Comment 2

17 years ago
absolutely!

*** This bug has been marked as a duplicate of 122227 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
yes...that would be a dup, wouldn't it.
Status: RESOLVED → VERIFIED

Comment 4

17 years ago
Is this really a duplicate?

Using build 2002021423, I am seeing Mozilla *inserting* <base href="file://..">,
though it wasn't there originally.

There are two problems: 

* That this is a local href (which is perhaps a duplicate of 122227
* That it appears *at all*.

I cannot get rid of it even by removing it manually from the HTML. As soon
as I save, it reappears.

And my build does not make other relative links absolute, so how can it
be a duplicate?

Please consider reopening this bug, as it can not be verified to be a duplicate.

Comment 5

17 years ago
The complaint in this bug is that the base href is being absolutized.  So, yes,
this is a duplicate of the bug indicated.

The problem in comment 4 is a duplicate of bug 125070.

Comment 6

17 years ago
Creating a new file it adds base href=about:blank.  I'm hoping that's the same
issue.

Comment 7

16 years ago
reassign in case bugs are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.