Format=flowed doesn't remove trailing space if that space is also a leading space. I.e., a line of a single space becomes space-stuffed and preserved

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: jonathan.chiarella, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160413222546

Steps to reproduce:

Write an email message in format=flowed.

Have one line be blank except for a single space.


Actual results:

Thunderbird adds a space at the beginning of the line. Thunderbird space-stuffs the space to preserve it.


Expected results:

Thunderbird should not preserve that space. Though the space is a leading space, there is no other content on the line, meaning that the space is, in fact, a trailing space.

(The likely scenario is when a user accidentally inserted a space on a blank line as such:

Lorem
 
Ipsum
)
(Reporter)

Comment 1

2 years ago
I have noticed that this line of only spaces does not make a flowed line (at least not in Thunderbird). I think this may be an artefact of older general internet standards like RFC1835 which have used a line of only whitespace in a significant way.
(Reporter)

Comment 2

2 years ago
After testing around, I don't think this is a problem anywhere. The IETF's RFCs ae quite long but very sparse on details it seems. A lot of trial and error to figure out e-mail works and formats itself. Since I've begun using PGP there is a necessity for bit-for-bit reproducibility and predictable results.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.