Hover popup has black background in the search bar and on youtube.com

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: cristiach, Unassigned, NeedInfo)

Tracking

46 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [platform-rel-Youtube])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8746608 [details]
hover_popups_black_kubuntu_14_04_64_bit_firefox_46.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160425115534

Steps to reproduce:

Hover over the search bar and wait for the popup. Alternatively do the same thing on youtube.com video links.


Actual results:

The popup is black text on black background.


Expected results:

The popup is black text on white background.

Comment 1

2 years ago
Did you see this issue with the previous version of Firefox, 45?

Are you using Gtk3 on your machine? (46 supports Gtk3 now)
Flags: needinfo?(cristiach)
OS: Unspecified → Linux
(Reporter)

Comment 2

2 years ago
Immediately after updating from firefox 45 to 46 the issue appeared.

I use a KDE long term support distribution, so I do not belive that there is anything going on with gtk3.

Comment 3

2 years ago
Can you run mozregression to find a regression range, please.
See http://mozilla.github.io/mozregression/ for details.

You can try the command "mozregression --good=45" then copy here the final pushlog provided by the console.

Updated

2 years ago
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

2 years ago
For good=45 and good=44 I get the same black text on black background results. I am thinking that mabe there is some configuration option read by the nightly builds as well that is borked. If that is the case, the Firefox package being a distribution packaged update, it has nothing to do with the official Mozilla installer. Though I could still use some help in tracking down the issue.

PS I ran mozregression with firefox stable closed as well to ensure that wasn't causing any issues.

brancoliticus@brancoliticus-EP41-UD3L:~$ mozregression --good=45
 0:00.52 INFO: No 'bad' option specified, using 2016-04-30
 0:00.52 INFO: Using date 2015-12-14 for release 45
 0:07.23 INFO: Testing good and bad builds to ensure that they are really good and bad...
 0:07.24 INFO: Downloading build from: https://archive.mozilla.org/pub/firefox/nightly/2015/12/2015-12-14-12-22-42-mozilla-central/firefox-46.0a1.en-US.linux-x86_64.tar.bz2
===== Downloaded 100% =====
 0:34.39 INFO: Running mozilla-central build for 2015-12-14
 0:56.61 INFO: Launching /tmp/tmpnhVZL8/firefox/firefox
 0:56.64 INFO: application_buildid: 20151214122242
 0:56.64 INFO: application_changeset: 06ab805e14b5e6d8a8a99c7846c8fde163a9e5d7
 0:56.64 INFO: application_name: Firefox
 0:56.65 INFO: application_repository: https://hg.mozilla.org/mozilla-central
 0:56.65 INFO: application_version: 46.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry' or 'exit' and press Enter): bad <---- OH BOY ---->
 1:20.63 ERROR: Build was expected to be good! The initial good/bad range seems incorrect.

Comment 5

2 years ago
If you download and try the official Linux build from Mozilla, does it work as expected?
https://www.mozilla.org/en-US/firefox/all/
Keywords: regressionwindow-wanted

Comment 6

2 years ago
I can reproduce this bug. I'm using 46.0 Elementary OS Freya (based on Ubuntu 14.04 64bit). When the house hover on AdblockPlus, a black dialogue will appear.

For an older version (I don't know exactly which one, it's upgraded by `apt-get upgrade`), I ddin't notice this problem.

Comment 7

2 years ago
When the house hover on hyper links on the web page or on links of bookmarks, the popup also has black ground.

Comment 8

2 years ago
Hello reporter, I tried to  duplicate this issue on the following FF versions
Version 	49.0a1
Build ID 	2016050503032 	
Update Channel 	nightly
User Agent 	Mozilla/5.0 (X11; Linux i686; rv:49.0) Gecko/20100101 Firefox/49.0

Version 	45.0a1
Build ID 	20151120030227	
Update Channel 	nightly
User Agent 	Mozilla/5.0 (X11; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0

Version 	46.0.1
Build ID 	20160502172042
Update Channel 	release
User Agent 	Mozilla/5.0 (X11; Linux i686; rv:46.0) Gecko/20100101 Firefox/46.0

Version 	43.0
Build ID 	20151210163017
User Agent 	Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:43.0) Gecko/20100101 Firefox/43.0

I observe same behavior on all above versions: White text on black background. Can you please answer the Loic's question? Thanks!

Comment 9

2 years ago
I downloaded the latest version (46.0.1 Linux b4bit). It does have white text on black background. To my surprise, I can see the text clearly this time. The problem is gone permanently. Does the build from https://www.mozilla.org/en-US/firefox/all/ override some settings?
 
I can't recall what's the real situation before. Maybe it also has hover popup with black background? But what I am sure is that I can't see the text clearly (because of the color?) before.

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
Whiteboard: [platform-rel-Youtube]

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Comment 10

2 years ago
Hi there, I am using a version from https://www.mozilla.org/en-US/firefox/all/ and I am having this issue.  I am not having this issue in other gtk3 apps, and also not in other firefox-based browsers.  I have tried making a new profile in firefox as well (black on black).  I have tried mozregression but it seems both versions (2009-01-01 and 2017-02-12) work fine (black on grey).  `-b 51` also works fine.  I tried safe mode as well (doesn't work).

This would indicate to me that there is some important difference between nightly and release, but I don't know where to look next.
You need to log in before you can comment on or make changes to this bug.