Firefox download page offers old version

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: botond, Unassigned)

Tracking

Production
x86_64
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

STR:
  1. Go to www.mozilla.org -> Firefox -> Firefox for Desktop.
  2. Click the Download link. Its URL is 
     https://www.mozilla.org/en-US/firefox/new/?scene=2

Expected results:
  I'm offered to download the latest release, 46.0

Actual results:
  I'm offered to download 43.0.1.
Are you on XP or Vista? It's an intentional behaviour:
https://support.mozilla.org/en-US/kb/get-latest-version-firefox-windows-xp-vista
I'm on Windows XP.

Note that, contrary to the claim made in that article, I was able to install Firefox 46.0 directly from https://ftp.mozilla.org/pub/firefox/releases/46.0/win32/en-US/Firefox%20Setup%2046.0.exe just fine.
(In reply to Botond Ballo [:botond] from comment #2)
> I'm on Windows XP.

I should clarify that I'm on 64-bit Windows XP. SP2 is the latest service pack for that, and it probably contains whatever newer Firefox installers need from SP3 for 32-bit Windows XP.
Hi Joni-

Is this the expected behavior?

Thx,
Jen
Flags: needinfo?(jsavage)
Thanks for flagging this. I just checked with the team. This is expected behavior for the article, since having SP3 is still the most consistent and reliable way to download the latest version.

There might be special circumstances as noted in the previous comment (I don't know all of them), but they might be too complicated or unreliable for the general user. The article does contain the FTP link for "advanced" users so they can directly download the newest version.
Flags: needinfo?(jsavage)
Closing as per the previous comment.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.