Plugin block list blocks SWF network requests, but does not prevent plugin instantiation (e10s-compatible fix for Aurora 48+)

RESOLVED DUPLICATE of bug 1268120

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 1268120
a year ago
a year ago

People

(Reporter: cpeterson, Assigned: tobytailor)

Tracking

(Blocks: 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s-, firefox46 unaffected, firefox47 wontfix, firefox48 affected, firefox49 affected)

Details

(Reporter)

Description

a year ago
+++ This bug was initially created as a clone of Bug #1266889 +++

We don't want to load the plugin when we're going to block the SWF anyways. We need to check the block list before instantiating the plugin.

The plugin instantiation fix in bug 1266889 is not e10s-compatible, but that is OK for Beta 47 when e10s is not enabled. We need an e10s-compatible fix for Aurora 48+, where e10s is enabled by default.

Updated

a year ago
tracking-e10s: --- → -
(Reporter)

Comment 1

a year ago
Tobias said he will add an end-to-end test to verify that plugin instantiation blocking actually works, instead of just testing channel classification.
(Reporter)

Updated

a year ago
Blocks: 1277876
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1268120
You need to log in before you can comment on or make changes to this bug.