Closed Bug 1268822 Opened 5 years ago Closed 5 years ago

ASSERTION: Mismatched sizes were recorded in the memory leak logging table.

Categories

(Core :: Audio/Video: GMP, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: jwwang, Assigned: jwwang)

References

Details

Attachments

(1 file)

|./mach mochitest dom/media/test/test_eme_stream_capture_blocked_case3.html|

Hit this assertion when running mochitest on Linux.

[GMP 10267] ###!!! ASSERTION: Mismatched sizes were recorded in the memory leak logging table. The usual cause of this is having a templated class that uses MOZ_COUNT_{C,D}TOR in the constructor or destructor, respectively. As a workaround, the MOZ_COUNT_{C,D}TOR calls can be moved to a non-templated base class.: 'aInstanceSize == 0 || entry->GetClassSize() == aInstanceSize', file xpcom/base/nsTraceRefcnt.cpp, line 463
#01: NS_LogAddRef (xpcom/base/nsTraceRefcnt.cpp:1105)
#02: mozilla::gmp::Runnable::AddRef() (dom/media/gmp/GMPPlatform.cpp:30 (discriminator 2))
#03: mozilla::gmp::RunOnMainThread(GMPTask*) (dom/media/gmp/GMPPlatform.cpp:124)
#04: mozilla::gmp::GMPChild::RecvBeginAsyncShutdown() (dom/media/gmp/GMPChild.cpp:544)
#05: mozilla::gmp::PGMPChild::OnMessageReceived(IPC::Message const&) (obj-x86_64-pc-linux-gnu/ipc/ipdl/PGMPChild.cpp:570)

It looks like NS_LOG_ADDREF/NS_LOG_RELEASE can't distinguish mozilla::gmp::Runnable from mozilla::Runnable as NS_INLINE_DECL_THREADSAFE_REFCOUNTING takes the unqualified name.
Assignee: nobody → jwwang
Version: 47 Branch → unspecified
Probably due to the recent renaming of mozilla::nsRunnable to Runnable in bug 1265927.
Blocks: 1265927
Rank: 15
Priority: -- → P1
Comment on attachment 8747022 [details]
MozReview Request: Bug 1268822 - rename mozilla::gmp::Runnable/SyncRunnable in order not to confuse NS_LOG_ADDREF/NS_LOG_RELEASE. r=gerald.

https://reviewboard.mozilla.org/r/49683/#review46505

stealing review
Attachment #8747022 - Flags: review+
Attachment #8747022 - Flags: review?(gsquelart)
"Runnable" is a bad name to choose for things, kinda like "Object". :-)  Too obvious, and before this there wasn't a conflict with nsRunnable, so it was open for everyone else to use, and surprise, they did.
Thanks for the review!
https://hg.mozilla.org/mozilla-central/rev/cd65ab909d3d
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.