Status

()

Core
Widget: Gtk
--
major
RESOLVED DUPLICATE of bug 1230955
2 years ago
2 years ago

People

(Reporter: George, Unassigned)

Tracking

46 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160427000438

Steps to reproduce:

Update to Firefox 46 :-(


Actual results:

With the switch to GTK3 the browser now looks like **** (see attached screenshot with the crazy wireframe thing going on).

Most importantly though there is no longer an "handle" on the scroll bar, so not possible to see where the scroll is at, or the total length of the page.


Expected results:

Scroll bar should work.
(Reporter)

Comment 1

2 years ago
Created attachment 8747051 [details]
Screenshot from 46
(Reporter)

Updated

2 years ago
Severity: normal → major
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Updated

2 years ago
Attachment #8747051 - Attachment description: ff_bz_1268874.png → Screenshot
(Reporter)

Comment 2

2 years ago
Is there a config option to switch back to GTK2?
(Reporter)

Comment 3

2 years ago
OS is Debian Sid. GTK versions:

```
$ dpkg -l libgtk* | grep -e '^i' | grep -e 'libgtk-*[0-9]'
ii  libgtk-3-0:amd64             3.20.3-1      amd64        GTK+ graphical user interface library
ii  libgtk-3-bin                 3.20.3-1      amd64        programs for the GTK+ graphical user interface library
ii  libgtk-3-common              3.20.3-1      all          common files for the GTK+ graphical user interface library
```
(Reporter)

Comment 4

2 years ago
Looks like the same as bug 1261576? If this is a known issue then pushing out GTK3 in FF 46 is a big WTF! :-(
(Reporter)

Comment 5

2 years ago
Created attachment 8747057 [details]
Screenshot from 45 ESR

Adding a screenshot of FF 45 ESR for comparison
(Reporter)

Updated

2 years ago
Attachment #8747051 - Attachment description: Screenshot → Screenshot from 46
Blocks: 627699
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Comment 6

2 years ago
Bug confirmed, scrollbar is invisible in every condition.

Reproduced with a black scrollbar on Archlinux/Gnome 3.20 & black coloured Gnome.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1230955
You need to log in before you can comment on or make changes to this bug.