Reducing tab height causes a gap above tabs

VERIFIED INVALID

Status

()

VERIFIED INVALID
3 years ago
a year ago

People

(Reporter: rackord, Unassigned)

Tracking

48 Branch
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8747147 [details]
output.webm

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20160429004052

Steps to reproduce:

@namespace xul url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

:root {
    --space-above-tabbar: 0 !important;
}
#TabsToolbar, #tabbrowser-tabs {
  height: 24px !important; min-height: 24px !important;
  background: grey !important;
}


Actual results:

As soon as you move or maximize / restore or resize the window a gap appears above the tabs.
(Reporter)

Updated

3 years ago
Component: Untriaged → Theme
(Reporter)

Comment 1

3 years ago
As i said reducing tab height makes a gap above tabs appear (see video). 

To modify tab height you can use userChrome.css, stylish, thin tabs, classic theme restorer... changing the color to a darker one should make easier to see the problem, the code provided above is a good example.

This wasn't happening before so i tried to investigate the possible causes and found this:
https://bugzilla.mozilla.org/show_bug.cgi?id=1256731

I am quite sure this "fix" is causing the problem.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows

Comment 2

3 years ago
Bugs that only reproduce with custom CSS are not bugs in Firefox, so resolving this as invalid.

In order to fix your issue, you'll need to make sure the titlebar's content height is no bigger than that of the tabs, because you reduced the size of the tabs. The result after the resize actually looks correct to me in that the titlebar buttons are otherwise half-covered - resizing the titlebar buttons may be enough to accomplish what you want, or you may need to resize the titlebar as well;

If you want to change the background color, change the background color of the titlebar as well.

Dealing with Fitts' law issues with the tabs in maximized windows in circumstances similar to this one is bug 1257792.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

3 years ago
(In reply to :Gijs Kruitbosch from comment #2)
> Bugs that only reproduce with custom CSS are not bugs in Firefox, so
> resolving this as invalid.
> 
> In order to fix your issue, you'll need to make sure the titlebar's content
> height is no bigger than that of the tabs, because you reduced the size of
> the tabs. The result after the resize actually looks correct to me in that
> the titlebar buttons are otherwise half-covered - resizing the titlebar
> buttons may be enough to accomplish what you want, or you may need to resize
> the titlebar as well;
> 
> If you want to change the background color, change the background color of
> the titlebar as well.
> 
> Dealing with Fitts' law issues with the tabs in maximized windows in
> circumstances similar to this one is bug 1257792.

Worked fine before and broke after this bug was fixed https://bugzilla.mozilla.org/show_bug.cgi?id=1256731

Now you can even remove the titlebar's content buttons and all and it keeps creating a gap.
(Reporter)

Comment 4

3 years ago
Created attachment 8748144 [details]
No content.PNG

No titlebar content no buttons, still gap, works fine before (and still works on stable)
(Reporter)

Comment 5

3 years ago
Created attachment 8748147 [details]
stable.PNG

Stable
(Reporter)

Comment 6

3 years ago
Created attachment 8748148 [details]
Developer edition (aka aurora)
(Reporter)

Updated

3 years ago
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: INVALID → ---

Comment 7

3 years ago
(In reply to Sergio from comment #3)
> Worked fine before and broke after this bug was fixed
> https://bugzilla.mozilla.org/show_bug.cgi?id=1256731

Lots of custom CSS might break when we fix bugs. That's the nature of hacking on a product in ways that aren't supported.

> Now you can even remove the titlebar's content buttons and all and it keeps
> creating a gap.

Screenshots don't help. The only thing that would be useful here would be the CSS that you're using.

In any case, as I said before, there is nothing about this configuration that is supported, and we won't be changing Firefox to accommodate such a configuration. Your best bet is to -moz-appearance: none !important all the relevant titlebar elements and ensure they have as much or less height than the tabs toolbar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → INVALID

Updated

3 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

3 years ago
The css is in the 1st comment and in the screenshots.
Flags: needinfo?(gijskruitbosch+bugs)

Comment 9

3 years ago
(In reply to Sergio from comment #8)
> The css is in the 1st comment and in the screenshots.

... but not the additional CSS I have since suggested.
Flags: needinfo?(gijskruitbosch+bugs)
(Reporter)

Comment 10

a year ago
JFYI this erratic behavior seems to be fixed on 2017-06-17 nightly.
(Reporter)

Comment 11

a year ago
(In reply to Sergio from comment #10)
> JFYI this erratic behavior seems to be fixed on 2017-06-17 nightly.

false alarm it's just a little better now but still broken.
You need to log in before you can comment on or make changes to this bug.