Closed Bug 1268998 Opened 4 years ago Closed 4 years ago

Intermittent testUnifiedTelemetryClientId | Client ID from JS equals ID from Java - got 62a8cfd1-79e2-4b2d-bffb-1f3e6656cb91, expected 80b24c08-8327-4f0c-93ed-61c340cb1ea6

Categories

(Firefox for Android :: Metrics, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1270191
Tracking Status
firefox49 --- affected

People

(Reporter: KWierso, Assigned: mcomella)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Flags: needinfo?(michael.l.comella)
Wes, I have there been any more failures of this? I can't seem to find anything.
Assignee: nobody → michael.l.comella
Flags: needinfo?(michael.l.comella) → needinfo?(wkocher)
I see only two instances, both from a few days ago: https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1268998
Flags: needinfo?(wkocher)
Both of the failures Wes pointed to in comment 2 are:
  testUnifiedTelemetryClientId | Client id file does not exist yet

which looks to be bug 1261494. As such, I think this bug is WORKSFORME – perhaps this intermittent was an intermediate state (e.g. caused by the possible race condition fixed by bug 1255657?).
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
From the logs:

05-22 16:34:33.929  2804  2817 I Robocop : {"message":"","time":1463960073893,"source":"robocop","status":"PASS","test":"testUnifiedTelemetryClientId","thread":null,"subtest":"Waiting for Toolbar to enter editing mode.","action":"test_status","pid":null}
05-22 16:34:34.118  2804  2851 D GeckoTelemetryUploadSer: Telemetry upload success!
05-22 16:34:34.158  2804  2851 D GeckoTelemetryUploadSer: Service finished: upload and prune attempts completed

It looks like the TelemetryUploadService is running at the same time as this test, which could be causing it to write a new client ID file while we're testing (ouch!). I expect bug 1270191 (don't run the uploader in automation) to fix this issue.
Depends on: 1270191
I expect this to go away with the landing of bug 1270191 – please reopen if not so.

The failure rate is low enough that I don't think we need to uplift to aurora.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1270191
You need to log in before you can comment on or make changes to this bug.