Closed Bug 1269065 Opened 4 years ago Closed 3 years ago

AccessibleCaret detachs nsICaret, scrolls with APZ

Categories

(Core :: DOM: Selection, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1273045

People

(Reporter: capella, Unassigned)

References

(Blocks 1 open bug)

Details

Says it all, noticed with Android/Fennec ... STR [0] ....
   ) Navigate to the about:config page
   ) Add a text string to populate the |Search| field (I used |active|)
   ) Scroll down the filtered prefs list a bit
   ) Tap into the |Search| field

I notice two things:
   ) Something auto scrolls the page.
   ) When the AccessibleCaret becomes visible visible, it scrolls away with the page.


As a separate issue, I'm not sure what causes the auto-scroll. I wrote most of code involved for mobile/about:config, and didn't include anything for this behaviour. You can observe it with or without text populating the search field.

Also, I've noticed similar auto-scroll on other scrolled pages involving touches near the top / AwesomeBar, particularly Breitbart.com. (Scroll down the page, tap near top, page jumps back up to the top).


Finally, this seems to be fallout from:
   ) Bug 1249201 - Continue showing AccessibleCaret when scrolling or panning the page

As disabling "layout.accessiblecaret.always_show_when_scrolling" seems to correct it.


[0] https://www.dropbox.com/s/6o5e2uvx0nac4so/bug_Caret_Scroll.mp4?dl=0
This should be fixed by bug 1273045.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1273045
You need to log in before you can comment on or make changes to this bug.