Does not offer Terminus fonts in Preferences (installed under /usr/share/fonts/)

RESOLVED DUPLICATE of bug 1243194

Status

()

Core
Graphics: Text
RESOLVED DUPLICATE of bug 1243194
2 years ago
2 years ago

People

(Reporter: Javier, Unassigned)

Tracking

46 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160428052435

Steps to reproduce:

Preferences -> Content -> Advanced-Fonts -> Monospace

Searching for Terminus Fonts


Actual results:

FF didn't offer the Terminus fonts.


Expected results:

As before, FF should have been able to offer Terminus fonts if available in the system.

In my case they are:

% fc-list | 'grep' Terminus | wc -l
36

% xlsfonts | 'grep' terminus | wc -l
780

% fc-list | 'grep' Terminus
/usr/share/fonts/misc/ter-120b.pcf.gz: Terminus:style=Bold
/usr/share/fonts/misc/ter-x12b.pcf.gz: Terminus:style=Bold
...
/usr/share/fonts/misc/ter-x18n.pcf.gz: Terminus:style=Regular
/usr/share/fonts/misc/ter-x20n.pcf.gz: Terminus:style=Regular
...

% xlsfonts | 'grep' terminus
-xos4-terminus-bold-r-normal--0-0-72-72-c-0-iso10646-1
-xos4-terminus-bold-r-normal--0-0-72-72-c-0-iso10646-1
...
-xos4-terminus-medium-r-normal--0-0-72-72-c-0-iso10646-1
-xos4-terminus-medium-r-normal--0-0-72-72-c-0-iso10646-1
...

I'm currently using FF 46.0, and I'm unable to use my preferred font, but this started on one of the FF 45 latest versions.  I can't remember the version FF started to fail detect the Terminus fonts.

BTW, mozregression doesn't help provide the exact build FF started to fail on the Terminus fonts, because now it's always failing trying to detect the fonts.  Weird thing, GVim is OK finding the terminus fonts...
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

2 years ago
Summary: unable to offer terminus fonts (my preferred monospace font) → Does not offer Terminus fonts in Preferences (installed under /usr/share/fonts/)

Updated

2 years ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Duplicate of this bug: 1269072

Comment 2

2 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

2 years ago
It appears to be a regression in 46, could you run Mozregression to find a regression range, please.
http://mozilla.github.io/mozregression/

Try the command "mozregression --good=45" then copy here the final pushlog provided by the console.
Flags: needinfo?(j.e.vasquez.v)
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

2 years ago
I tried it again without bad, and just good for 45...  Same results as using 44 as good.  No Terminus fonts offered by FF.  So mozregression can't help on my side.  Sorry about that.
Flags: needinfo?(j.e.vasquez.v)

Comment 5

2 years ago
Dup Bug 1245811 ?
(Reporter)

Comment 6

2 years ago
That bug was found on FF 44.  This one in one of the last 45 (was working even in early 45).  So that makes it a bit different, :-)
Terminus is a bitmap font, isn't it? In which case, see bug 1243194.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1243194

Comment 8

2 years ago
I am not so sure it is a dupe. That bug says about setting a bitmap font as a default. The bug here and 
bug 1269072 just note that in the font configuration dialog "Advanced-Fonts" in the "Fixed" menulist (whose purpose is to display monospace fonts) the Terminus font is missing. While other fonts are not.
This is about settings Terminus as the default font for all pages or something. Only for the part that indend to use a monospaced font (maybe page source?).
Doesn't matter whether you're trying to use it as a (general) default, as the default for monospace, as a specific font via font-family, or what.... the issue is simply that the new fontconfig backend doesn't support bitmap fonts, as described in bug 1243194. And Terminus is a bitmap font, yes? Hence, doesn't appear.

Comment 10

2 years ago
Ah yes, you mean the difference of bitmap fonts to vector fonts like TTF/OTF, which may also be monospaced.

A quick Google search shows up there are TTF versions of Terminus. We can try that.
You need to log in before you can comment on or make changes to this bug.