Firefox (and Thunderbird) does not offer Terminus fonts in Preferences (installed under /usr/share/fonts/)

RESOLVED DUPLICATE of bug 1269069

Status

()

RESOLVED DUPLICATE of bug 1269069
3 years ago
3 years ago

People

(Reporter: j.e.vasquez.v, Unassigned)

Tracking

45 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160428052435

Steps to reproduce:

Preferences -> Display -> Advanced-Fonts -> Monospace

Preferences -> Composition -> General -> HTML-Font 


Actual results:

Both preferences are not offering any more the Terminus fonts as an option.


Expected results:

Both preferences were able to select the Terminus fonts available in the system before.  That was working fine on the 44 latest version I was using, but now on the 45 version the Terminus fonts are no longer offered.

The fonts are available in the system:

% fc-list | 'grep' Terminus | wc -l
36

% xlsfonts | 'grep' terminus | wc -l
780

% fc-list | 'grep' Terminus
/usr/share/fonts/misc/ter-120b.pcf.gz: Terminus:style=Bold
/usr/share/fonts/misc/ter-x12b.pcf.gz: Terminus:style=Bold
...
/usr/share/fonts/misc/ter-x18n.pcf.gz: Terminus:style=Regular
/usr/share/fonts/misc/ter-x20n.pcf.gz: Terminus:style=Regular
...

% xlsfonts | 'grep' terminus
-xos4-terminus-bold-r-normal--0-0-72-72-c-0-iso10646-1
-xos4-terminus-bold-r-normal--0-0-72-72-c-0-iso10646-1
...
-xos4-terminus-medium-r-normal--0-0-72-72-c-0-iso10646-1
-xos4-terminus-medium-r-normal--0-0-72-72-c-0-iso10646-1
...

GVim for example is having no problems offering the Terminus fonts.  Not sure what's going on with TB neither FF (Firefox is also failing to offer Terminus fonts since some of its 45 versions and now on its 46 version).

Notice mozregression doesn't help me at all, given TB fails to select Terminus fonts when I select 43 as good, and TB was detecting Terminus fonts fine on version 44, so not useful for this...
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

3 years ago
Yes, I can confirm this.
But I think Thunderbird does not do anything special with enumerating fonts.

This can also be seen in Firefox (preferences->Content->advanced...->fixed width font, menulist does not contain Terminus.
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Text
Ever confirmed: true
Product: Thunderbird → Core
Hardware: x86_64 → All

Updated

3 years ago
Summary: Thunderbird fails to offer Terminus fonts → Thunderbird does not offer Terminus fonts in Preferences (installed under /usr/share/fonts/)

Updated

3 years ago
Summary: Thunderbird does not offer Terminus fonts in Preferences (installed under /usr/share/fonts/) → Firefox (and Thunderbird) does not offer Terminus fonts in Preferences (installed under /usr/share/fonts/)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: Layout: Text → Graphics: Text
Resolution: --- → DUPLICATE
Duplicate of bug: 1269069
You need to log in before you can comment on or make changes to this bug.