If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No templates should be in the admin directory.

RESOLVED DUPLICATE of bug 135707

Status

()

Bugzilla
Administration
P1
blocker
RESOLVED DUPLICATE of bug 135707
16 years ago
5 years ago

People

(Reporter: CodeMachine, Assigned: justdave)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Templates should be in a subdirectory of 'admin', eg users, resolutions, groups,
common, etc.

There are currently templates in the admin directory directly.  This will be
real ugly when the admin whackage lands if not fixed.
(Reporter)

Updated

16 years ago
Target Milestone: --- → Bugzilla 2.16
(Reporter)

Comment 1

16 years ago
If these are for createacccount.cgi, as I suspect, I don't think they should
even be in "admin".

Comment 2

16 years ago
One of the templates (change-password.html.tmpl) is for token.cgi, which is
being extended in bug 23067.  It would be good to have a new sub-directory name
chosen for account maintenance templates before bug 23067 is pushed in, as it is
currently using a new sub-directory 'token'.
this needs to either be dealt with or wontfixed before we release 2.16, so
making it a blocker.
Severity: normal → blocker
Priority: -- → P1
Blocks: 97495
Created attachment 78235 [details] [diff] [review]
patch v1: moves files around

This patch moves change-password to the token directory and the other files to
the new account directory (normalizing their names per bug 135707 in the
process).
Comment on attachment 78235 [details] [diff] [review]
patch v1: moves files around

Forget this patch and let's do this as part of bug 135707.
Attachment #78235 - Flags: review-
Depends on: 135707
There are no templates in the template/en/default/admin directory.

Gerv

*** This bug has been marked as a duplicate of 135707 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
clearing target milestone on invalid/duplicate/worksforme/wontfix bugs so
they'll show up as untriaged if they get reopened.
Target Milestone: Bugzilla 2.16 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.