NEW URL Results bug with browser.urlbar.unifiedcomplete;false

VERIFIED WONTFIX

Status

()

Firefox
Address Bar
VERIFIED WONTFIX
2 years ago
a year ago

People

(Reporter: Sergio, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8747421 [details]
url results bug.webm

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/600.5.17 (KHTML, like Gecko) Version/8.0.5 Safari/600.5.17
Build ID: 20160429004052

Steps to reproduce:

Clean profile, browser.urlbar.unifiedcomplete;false and visit some webs (the recommended ones in the tiles will suffice).


Actual results:

With browser.urlbar.unifiedcomplete;false sometimes when you start typing the first letter of a web you want to visit the results shown are wrong but clicking it sends you to the correct web anyway cause the webs shown doesn't match the webs you'll visit once you click. (see the video provided).
(Reporter)

Updated

2 years ago
Component: Untriaged → Location Bar
Hi, thank you for your report.
Unfortunately that options is deprecated and not officially supported. See bug 1223728.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

2 years ago
I'll inform about this to the people that had rolled back to previous version cause this, and provide them a workaround to remove the "visit url" from the bar.

If someone need it use this code (userchrome or stylish):

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

#PopupAutoCompleteRichResult > richlistbox > richlistitem[actiontype="visiturl"] {
  display: none !important;
}
(Reporter)

Updated

2 years ago
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: WONTFIX → ---
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WONTFIX

Updated

2 years ago
Status: RESOLVED → VERIFIED
Flags: needinfo?(gijskruitbosch+bugs)

Comment 3

2 years ago
So, Firefox intentionally breaks usability for anyone actually NOT doing any search from the URL bar? Just to remind you: if one does not use search from URL bar, this unstoppable new "feature" becomes completely, totally equivalent of hitting ENTER, thus actually worsens user experience of looking up pages from history using a few keystrokes only.
Even if you don't search, the awesomebar keeps working as usual. The behavior doesn't change from years, the only changed thing is the way results are presented, where now the first row indicates the action, that is the same action as before. You may not like, that's fine, but it will help millions of users better understanding the urlbar behaviors.
(Reporter)

Comment 5

a year ago
(In reply to spyer from comment #3)
> So, Firefox intentionally breaks usability for anyone actually NOT doing any
> search from the URL bar?

Yes, and I've seen lot of people complaining and asking how to revert this change since "browser.urlbar.unifiedcomplete" was removed, so maybe an official option to enable the old behavior will make lot of users happy.
You need to log in before you can comment on or make changes to this bug.