Closed Bug 1269194 Opened 6 years ago Closed 5 years ago

Make CheckerboardReportService accessible also outside of about:checkerboard

Categories

(Core :: Panning and Zooming, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: avih, Assigned: kats)

References

Details

Attachments

(1 file)

Currently the CheckerboardReportService API is blocked except if accessed from about:checkerboard.

I think it's OK that it requires privileged access (even though there's nothing secretive about it) but otherwise should not limit access to other Gecko code IMO.

The use case I have in mind right now is a talos APZ scroll test, but I still think it should be accessible to Gecko code in general.
ehsan, we added this CheckerboardReportService API back in bug 1238042 and exposed it to about:checkerboard (which we kept unprivileged) explicitly via the check at [1]. Do you have any concerns about relaxing the URL check and allowing any privileged code to access it? I agree with avi that there isn't really anything secretive about it.

[1] http://mxr.mozilla.org/mozilla-central/source/gfx/layers/apz/util/CheckerboardReportService.cpp?rev=77d65c5c2422&mark=136-136#129
Depends on: 1238042
Flags: needinfo?(ehsan)
Allowing privileged code access here seems fine to me!
Flags: needinfo?(ehsan)
Attached patch PatchSplinter Review
Does this work for you? I tested both e10s and non-e10s to verify that it is accessible in about:checkerboard and other chrome pages (like about:about) but is NOT accessible in web content or unprivileged pages like about:blank.
Attachment #8749745 - Flags: review?(avihpit)
Comment on attachment 8749745 [details] [diff] [review]
Patch

Review of attachment 8749745 [details] [diff] [review]:
-----------------------------------------------------------------

Confirmed works for me. Thanks.
Attachment #8749745 - Flags: review?(avihpit) → review+
https://hg.mozilla.org/mozilla-central/rev/d9bbd4950bc0
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.