Add ability to disable/restrict to access devtools for the user

RESOLVED DUPLICATE of bug 1408969

Status

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1408969
3 years ago
11 months ago

People

(Reporter: yuki, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Dependency tree / graph

Firefox Tracking Flags

(firefox49 affected)

Details

(Whiteboard: triaged)

Reporter

Description

3 years ago
For enterprise use, web developer tools are thought as dangerous and the system administrator hope to disable them completely - hide menus, toolbar buttons, and disable keyboard shortcuts to start them. Now we can do it via CSS (userChrome.css) and legacy addons, but after XUL is ended, we need something to alternate them.

Updated

3 years ago
Whiteboard: [design-decision-needed]triaged

Comment 1

3 years ago
I don't think there should be a specific WebExtension API for this. I'm not sure if the dev tools has an ideas about this though.

Updated

3 years ago
Component: WebExtensions: Untriaged → WebExtensions: General
We've been thinking about this recently.  Right now the current thinking is that DevTools may itself become an add-on that isn't installed by default.  Lifting ourselves outside the browser has a lot of benefits for us and would also likely give us a route to solving this enterprise issue.

See this discussion: https://groups.google.com/forum/#!topic/mozilla.dev.developer-tools/rUmAom_L3kc

Comment 3

3 years ago
So then this would likely fall under a general "don't allow add-ons to be installed" kind of setting?
(In reply to Andy McKay [:andym] from comment #3)
> So then this would likely fall under a general "don't allow add-ons to be
> installed" kind of setting?

In theory, yes. Though the technical details for how the devtools add-on would work have yet to be worked out.

Updated

3 years ago
Component: WebExtensions: General → General
Product: Toolkit → Firefox
Whiteboard: [design-decision-needed]triaged → triaged

Updated

3 years ago
Component: General → Developer Tools
With bug 1408969, DevTools can be disabled completely with a user pref.
I don't know if admins can prevent changes to user prefs, but if they can, this would solve this bug.
Severity: normal → enhancement
Priority: -- → P3
See Also: → dt-onboarding

Comment 6

2 years ago
(In reply to Patrick Brosset <:pbro> from comment #5)
> With bug 1408969, DevTools can be disabled completely with a user pref.
> I don't know if admins can prevent changes to user prefs, but if they can,
> this would solve this bug.

They can lock a pref ( http://kb.mozillazine.org/Lock_Prefs ), so yes.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: dt-onboarding

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.