Closed Bug 1269324 Opened 5 years ago Closed 5 years ago

Switching between tabs doesn't close browser action's pop-up

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set
normal

Tracking

(firefox49 affected)

RESOLVED DUPLICATE of bug 1171746
Tracking Status
firefox49 --- affected

People

(Reporter: ecfbugzilla, Unassigned)

Details

Attachments

(1 file)

832 bytes, application/x-xpinstall
Details
Attached file Minimal test extension
Steps to reproduce:

1. Download attached extension.
2. Go to about:config and set xpinstall.signatures.required to false.
3. Open Add-ons Manager and install the extension from file.
4. Click the extension's icon in the toolbar (generic puzzle icon).
5. Press Ctrl-Tab (Cmd-Tab on OS X) in order to switch to a different tab.

Expected results:

The extension's pop-up closes automatically - the content is likely related to the current tab and needs to be updated. That's what happens in Chrome.

Actual results:

The pop-up stays open.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171746
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.