Closed Bug 1269386 Opened 6 years ago Closed 4 years ago

Google Play Music doesn't allow enabling HTML5 Audio in Firefox

Categories

(Web Compatibility :: Desktop, defect)

x86_64
Windows 10
defect
Not set
normal

Tracking

(platform-rel +)

RESOLVED FIXED
Tracking Status
platform-rel --- +

People

(Reporter: ted, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-all][sitewait][platform-rel-Google])

Attachments

(4 files)

I'm running Firefox Nightly 49.0a1 (2016-05-01) on Windows 10. I do not have the Flash plugin installed on my system. If I visit Google Play Music (the URL in the URL field should take you right to the settings), I get a "Missing Flash Player" dialog, and if I click through that ("Not Now") the "HTML5 Audio" option under "Labs" is disabled.

The web console shows a few things, not sure if they're relevant:
```
'mozHidden' and 'mozVisibilityState' are deprecated.  Please use the unprefixed 'hidden' and 'visibilityState' instead.conversion.js:1:188
This file is deprecated. Please use `iron-flex-layout/iron-flex-layout-classes.html`, and one of the specific dom-modules insteadsj_srcs.js:21849:1
This file is deprecated. Please use `iron-flex-layout/iron-flex-layout-classes.html`, and one of the specific dom-modules insteadsj_srcs.js:21850:1
'mozHidden' and 'mozVisibilityState' are deprecated.  Please use the unprefixed 'hidden' and 'visibilityState' instead.pubads_impl_85.js:53:131
no element foundrequest:1:1
no element foundrequest:1:1
no element foundrequest:1:1
Empty string passed to getElementById().listen_extended_80d882f312bf67807b5b6042e9718ae316b77d10.js:2402:166
```
I notice that if I disable Flash in Chrome, the html5 audio option is also disabled.

However, I don't get a message telling me I need Flash.

Hallvord, can you look into why? One we know, we can perhaps use that to start a conversation with Google about fixing both issues.
Flags: needinfo?(hsteen)
Whiteboard: [country-all][needsdiagnosis]
Attached image gplay.png
Unfortunately this seems to work fine here - in my G Play preferences screen the HTML5 option is enabled and activated. It is in an "experimental" section with an added warning that it might not work consistently though. Is the one in the screenshot what you're talking about?
Flags: needinfo?(hsteen)
Yes, mine looks like this.
So - apologies, Mike, can't analyse this when it doesn't happen here :-/
Hallvord, are you running Windows 10?
Flags: needinfo?(hsteen)
Once I actually "start a free trial" the option is no longer enabled - odd :-o

I see however that in Chrome if I disable Flash, I get the same warning and the HTML5 option is equally disabled. So I guess the functionality just isn't ready and we don't need further research at this point.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(hsteen)
Resolution: --- → INVALID
Whatever it was that you guys were talking about in this bug, it is no longer correct. HTML playback is no longer a labs feature and cannot be turned off in Chrome.

Please reopen this.
Signed up for bugzilla just to agree with Ari here. HTML playback is no longer a labs feature.

Please reopen.
Flags: needinfo?(ted)
Thanks Ari.
ok let's see.

1. Go to https://play.google.com/music/listen#/now
2. Login dance
3. Back to https://play.google.com/music/listen#/now
4. Click on hamburger menu and choosing settings. Get redirected to
   https://play.google.com/music/listen#/accountsettings
   BUT with a message:  Couldn't open settings. Please try again. 

Probably because I didn't finish the process of registering. It requires a credit card information.

So to re-analyze this, we need someone with a Google Music account who's able to do investigation.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I am a Google Play Music user, so can I help with this? I'm running Firefox Dev Edition 52.0a2 (2017-01-04) (64-bit).

And I just uninstalled the flash player, and can confirm I get the "Flash Player not found" popup where I can select either to download it, or to ignore the warning but then I cannot play any music ofc.
Hi Carigan,

Thanks for the help.
If you can fake the user agent of Firefox on your computer I would love to know if it's working with a Google Chrome UA.


You could for example activate responsive design mode.
   Tools ➡ Web Developer ➡ Responsive Design Mode
And choose Nexus 7 in the list of devices
http://imgur.com/a/hK8d9
Flags: needinfo?(carighan)
I'm still seeing the "Missing Flash Player" message from Google Play music even with a Chrome UA. The extension I was using was: https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher-firefox/
When opening Google Play Music with responsive design set to Nexus 7 returns the following redirect: intent://play.google.com/music/listen#Intent;scheme=googleplaymusic;package=com.google.android.music;S.browser_fallback_url=https%3A%2F%2Fplay.google.com%2Fmusic%2Flisten%3Fnomobilenative%3D1;S.android.intent.extra.REFERRER_NAME=https%3A%2F%2Fplay.google.com%2Fmusic%2Flisten;end
(In reply to Karl Dubost :karlcow from comment #11)
> Hi Carigan,
> 
> Thanks for the help.
> If you can fake the user agent of Firefox on your computer I would love to
> know if it's working with a Google Chrome UA.
> 
> 
> You could for example activate responsive design mode.
>    Tools ➡ Web Developer ➡ Responsive Design Mode
> And choose Nexus 7 in the list of devices
> http://imgur.com/a/hK8d9

I tried the following UA:
Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.73 Safari/537.36

And it gave me weird results. I still get the "You need to upgrade your flash" popup, but it disappears after ~1 second, then it seems to try play the music 4-5 times, then it gives me a popup that Google Play Music cannot be reached.

Sorry, not the most technical of reports, I know :(
Flags: needinfo?(carighan)
Flags: needinfo?(ted)
Just to chime in--I still see this. I can reproduce it on my Mac as well. I'm using Nightly and I get the popup about Flash.
I can confirm that Google Play Music with Firefox (Fedora Linux) no longer has a Labs option to enable HTML5 audio (it's not just greyed out, it doesn't exist no more). For Firefox users the Flashplayer plug-in is strictly required. Don't know exactly when they removed that Labs option but it was quite some time ago. It doesn't matter if I set the Flashplayer plug-in to "Ask to activate", "Never activate" or remove it from the system. There will be no HTML5 fallback. No audio without Flash.

Google Chrome (Fedora Linux) always uses HTML5 audio. Although it comes with its own Flashplayer plug-in, it's not used for audio playback.

On a random basis (maybe depending on the user's IP address), Google is offering experimental HTML5 playback in Firefox to a small number of customers. I had it once, and with that outgoing IP address different Firefox instances on several computers were all (!) using HTML5 instead of Flash. Worked great! A lot more responsive. Sadly, all gone directly after the IP address had changed. Never got it again since. Has been confirmed by other users. See also https://bugzilla.redhat.com/show_bug.cgi?id=1405287

I've tried to contact Google about that but as everybody knows it's difficult to get a response from Google.

Don't know if the missing HTML5 audio playback is Firefox's fault at all. It's been verified that Google itself is handling customers differently (even with the very same OS, browser, and configuration). So maybe there's no way to enforce HTML5 on the client, because it's only Google who decides which users get HTML5 instead of Flash.

Anyway, I'm also offering my help for testing/debugging. I don't understand why Google is still using (and enforcing) Flash at all. On YouTube, the Flash/HTML5 auto-detection works much better.
Thanks a lot Andreas. 
There seems to be an issue with volume too. 
https://webcompat.com/issues/4683

Let me try to contact Google about it. :)
I contacted Google about it today.
Assignee: nobody → kdubost
Status: REOPENED → ASSIGNED
Whiteboard: [country-all][needsdiagnosis] → [country-all][sitewait]
platform-rel: --- → ?
Whiteboard: [country-all][sitewait] → [country-all][sitewait][platform-rel-Google]
platform-rel: ? → +
Pretty sure this is fixed, on my machine (which does not have flash installed), I'm getting audio and a bunch of range requests w/ audio/mp4 as a response.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.