Closed Bug 1269642 Opened 8 years ago Closed 5 months ago

[css-grid] Add display:grid support to HTML <details> element

Categories

(Core :: Layout: Grid, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1856374
Tracking Status
firefox49 --- affected

People

(Reporter: dholbert, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: dev-doc-needed)

In bug 1245430, we're adding display:flex support to details. If we're doing that, we should support "display:grid" as well (note that grid is enabled by default in Nightly builds).

So this would be for markup like:
  <details style="display:grid">
    <summary></summary>
    <div></div>
  </details>

Not sure exactly how it would render, but presumably it would be a logical extension of whatever we (and other browser engines) do for display:flex.
Summary: Add display:flex support to HTML <details> element → Add display:grid support to HTML <details> element
Blocks: css-grid
Summary: Add display:grid support to HTML <details> element → [css-grid] Add display:grid support to HTML <details> element
Severity: normal → S3
Component: Layout → Layout: Grid

Looks like we took care of this in bug 1856374 (still behind a pref for now). --> Duping.

Status: NEW → RESOLVED
Closed: 5 months ago
Duplicate of bug: 1856374
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.