Java plugin installed, Java enabled but apparently not recognized

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: mquiros, Assigned: joe.chou)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I had Java plugin installed and working with Netscape 4.79, I have installed
Mozilla 0.9.8 and made softlinks in /usr/lib/mozilla/plugins to javaplugin.so
and libjavaplugin_oji.so. Java is enabled in Preferences.
Despite so, I have found (for example, first URL) a message telling that the
information of type application/x-java-vm cannot be shown and asking me to
download the java plugin. If I look Help -> About Plugins, the Java plugin
shows up with an ugly name: (U]@(U]@ Plug-in 1.3.1_02-b02 and a mime type list
with application/x-java-applet and application/x-java-bean but without
application/x-java-vm.
I have also found (for example, second URL) a message asking me to enable Java
to view the contents of the page.
I do not know if both kinds of errors are related.
-> Oji
Assignee: idk → joe.chou
Component: Java-Implemented Plugins → OJI
QA Contact: avm → pmac

Comment 2

17 years ago
You need only to make symbolic link to 
  /path/to/your/jre/plugin/i386/ns600/libjavaplugin_oji.so
from mozilla/plugins.
You need *NOT* to make symbolic link to javaplugin.so (it's for netscape 4.x
only!)

Please, remove second symlink, check the correctness of link to
libjavaplugin_oji.so, remove component.reg and start mozilla again
and check about:plugins. It should work. 
Other test is to open java console. This should work too.

If not, then please clarify which jre do you use. post here output 
of ls -l plugins. 
(Reporter)

Comment 3

17 years ago
- Link to javaplugin.so removed.

- Link to libjavaplugin_oji.so rechecked.

- Result of ls -l /usr/lib/mozilla/plugins
lrwxrwxrwx    1 root     root           40 feb 15 16:53 libflashplayer.so ->
../../netscape/plugins/libflashplayer.so
lrwxrwxrwx    1 root     root           60 feb 12 15:35 libjavaplugin_oji.so ->
/usr/java/jre1.3.1_02/plugin/i386/ns600/libjavaplugin_oji.so
-rwxr-xr-x    1 root     root        18720 feb  7 06:15 libnullplugin.so

- Component.reg deleted.

- Restart mozilla as root. Component.reg recreated.

- Help -> About Plug-ins:
Only shockwave flash and default plugin show up.

- I try to enter in the same pages that did not work: They still do not work.
Java plugin is not recognized yet.

- I am able to start /usr/java/jre1.3.1_02/bin/ControlPanel. Should I change
any of the options that are shown here?

Comment 4

17 years ago
What is your linux distribution?
(Reporter)

Comment 5

17 years ago
Originally, it was Red Hat 6.1 but I have updated many things and
today it is probably closer to 7.something.
In particular:
glibc is 2.2.4
rpm is 4.0.3
kernel is 2.4.3

(Reporter)

Comment 6

17 years ago
I think that my problem is the same one described in
bugs 113141 and 116444. Is this right?

Comment 7

17 years ago
As far as i understood you did not compile mosilla yourself
Therefore you should not have mangling problem from bug 116444.

It could be the same as bug 113141 but it may be different as well.

Anyway, could you please try 
       ./run-mozilla.sh ./regxpcom /usr/local/mozilla/plugins/libjava*
    and 
       ./run-mozilla.sh /usr/bin/ldd /usr/local/mozilla/plugins/libjava* 
    post output here?
(Reporter)

Comment 8

17 years ago
I have not compiled Mozilla. I just downloaded and install the rpm. By the way,
it was installed in /usr/lib/mozilla instead of /usr/local/mozilla, so in
your suggestion I am replacing /local/ by /lib/. The results are:

./run-mozilla.sh ./regxpcom /usr/lib/mozilla/plugins/libjava*

**************************************************
nsNativeComponentLoader:
SelfRegisterDll(/usr/lib/mozilla/plugins/libjavaplugin_oji.so) Load FAILED with
error: /usr/lib/libglib-1.2.so.(
: shared object not open
**************************************************
Registration successful for /usr/lib/mozilla/plugins/libjavaplugin_oji.so

./run-mozilla.sh /usr/bin/ldd /usr/lib/mozilla/plugins/libjava*

	libnspr4.so => /usr/lib/libnspr4.so (0x4004b000)
	libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x40077000)
	libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x401ac000)
	libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x401e2000)
	libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x401e6000)
	libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4020b000)
	libstdc++-libc6.1-1.so.2 => /usr/lib/libstdc++-libc6.1-1.so.2 (0x40219000)
	libm.so.6 => /lib/libm.so.6 (0x4025b000)
	libc.so.6 => /lib/libc.so.6 (0x4027d000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x403b2000)
	libdl.so.2 => /lib/libdl.so.2 (0x403ca000)
	libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x403ce000)
	libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x403d6000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x2aaaa000)

From the first result, it looks like that Mozilla fails to find something
called /usr/lib/libglib-1.2.so.(
I have looked in the directory /usr/lib and I have found libglib-1.2.so.0
(it is a soft link to liglib-1.2.so.0.0.10).
It is possible that someone has written somewhere in the sources a "("
instead of a "0"?

Comment 9

17 years ago
No, i do not think so.
It looks like something is not correct with your environment.

Try 
  ldd  /usr/java/jre1.3.1_02/plugin/i386/ns600/libjavaplugin_oji.so

Expected result is something like 
 [nis@hercules mozilla]$ ldd
/usr/local/java/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so 
	libnspr4.so => not found
	libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x4004b000)
	libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x4016b000)
	libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x401a0000)
	libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x401a3000)
	libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x401c6000)
	libstdc++-libc6.1-1.so.2 => /usr/lib/libstdc++-libc6.1-1.so.2 (0x401d2000)
	libm.so.6 => /lib/libm.so.6 (0x40214000)
	libc.so.6 => /lib/libc.so.6 (0x40231000)
	libdl.so.2 => /lib/libdl.so.2 (0x40326000)
	libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x4032b000)
	libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40333000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

Other tests:
  ls -l /usr/lib/libglib-1.2.*
and
  ldd -r /usr/lib/libglib-1.2.so.0

Please post your output here.

(Reporter)

Comment 10

17 years ago
I've got the following:

ldd  /usr/java/jre1.3.1_02/plugin/i386/ns600/libjavaplugin_oji.so

	libnspr4.so => /usr/lib/libnspr4.so (0x4004b000)
	libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x40077000)
	libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x401ac000)
	libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x401e2000)
	libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x401e6000)
	libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4020b000)
	libstdc++-libc6.1-1.so.2 => /usr/lib/libstdc++-libc6.1-1.so.2 (0x40219000)
	libm.so.6 => /lib/libm.so.6 (0x4025b000)
	libc.so.6 => /lib/libc.so.6 (0x4027d000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x403b2000)
	libdl.so.2 => /lib/libdl.so.2 (0x403ca000)
	libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x403ce000)
	libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x403d6000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x2aaaa000)

It looks very similar to your example except for libnspr4, with appeared
as "not found" in your example and is found here.

ls -l /usr/lib/libglib-1.2.*

lrwxrwxrwx    1 root     root           21 may 22  2001
/usr/lib/libglib-1.2.so.0 -> libglib-1.2.so.0.0.10
-rwxr-xr-x    1 root     root       184771 abr 23  2001
/usr/lib/libglib-1.2.so.0.0.10

ldd -r /usr/lib/libglib-1.2.so.0

	libc.so.6 => /lib/libc.so.6 (0x4002d000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x2aaaa000)

Comment 11

17 years ago
I have the same problem, but it is with my own compiles as well as pre-built
binaries.

I'm using glibc-2.2.4, and have compiled almost everything on my system myself,
though the base install was SuSE.

I can't seem to change the status from unconfirmed, but I kinda think this
should be done.
(Reporter)

Comment 12

17 years ago
I have upgraded Mozilla to 0.9.9 (downloading and installing the RPMs) and,
without any further action, the problem has dissapeared. The plugin is now
recognized and is launched by the pages that require it.
I cannot figure out what the problem was and how it was solved but, however,
it seems to have been solved in the new version.

Comment 13

17 years ago
*** Bug 129180 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Miguel sad the problem has disappeared, so resolve this bug as wfm for now ?
..as of reporters comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 16

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.