IPV6 crashes in DNS resolving process

VERIFIED WORKSFORME

Status

()

Core
Networking: HTTP
--
critical
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: KONDOU, Kazuhiro, Assigned: Darin Fisher)

Tracking

({crash})

Trunk
x86
FreeBSD
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla crashes in DNS resolving process by IPv6 to IPv4 fallback correction.
(Bugzilla #86917 and Bugzilla #126755)
Probably, mismatching with DNS resolve mechanism occurred by this correction.

User requests a new HTTP request during DNS resolving is not finished before
request. Mozilla will crash.
This problem is not checking by IPv4. However, it is thought that it generates
in both IPv4 and IPv6.

Updated

17 years ago
Severity: major → critical
Keywords: crash
Summary: Mozilla crashes in DNS resolving process. → Mozilla crashes in DNS resolving process
(Assignee)

Comment 1

17 years ago
reporter: any chance you can reproduce this in a debug build and provide a stack
trace?
(Reporter)

Comment 2

17 years ago
I re-checked this problem on Mozilla current.
Mozilla current does not have this problem. And patched Mozilla current does not
have this problem with FreeBSD ports patches (www/mozilla), too.

This problem applied IPv6 to IPv4 fallback code to Mozilla 0.9.8 release
forcibly seems to be a cause.

This problem is peculiar to FreeBSD. It is unrelated to Mozilla.
Close this report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
fixed is wrong
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
QA Contact: tever → ipv6
Summary: Mozilla crashes in DNS resolving process → IPV6 crashes in DNS resolving process

Updated

10 years ago
Status: RESOLVED → VERIFIED
QA Contact: ipv6 → networking.http
You need to log in before you can comment on or make changes to this bug.