Signature change for crashes with ipc_message_error

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: benjamin, Assigned: adrian)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

User Story

* If the annotation "ipc_channel_error" is present:
** If the crash contains additional_minidumps=browser, the crash report signature shall be "IPCError-browser | " + ipc_channel_error[:100]
** Otherwise, the crash report signature shall be "IPCError-content | " + ipc_channel_error[:100]

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Content processes which are intentionally killed by the chrome process because of a processing error should have a signature which is distinct from a normal crash.

Examples of crashes that this may affect:
https://crash-stats.mozilla.com/report/index/b1445175-efbb-4e2d-b321-a85742160429
https://crash-stats.mozilla.com/report/index/c778e6b0-c397-4358-ab94-6dd0d2160429

There are currently unlikely to be any IPCError-content examples because of a bug in the client.
(Reporter)

Comment 1

3 years ago
We'd like to reprocess the affected set of crashes from 47beta after this change is made.
Adrian, does the description and User Story make enough sense for you to take on this bug? 

Benjamin, we are working on a feature whereby you can make a SuperSearch and pipe the results into reprocessing. It's not ready for many days (or weeks if it turns out to be complications). I'm guessing that's too long a wait? If it is, with your guidance I can manually make sure those matching crash IDs are reprocessed. 
Perhaps we make a dependent bug on this just about the reprocessing.
Flags: needinfo?(adrian)
(Assignee)

Comment 3

3 years ago
Created attachment 8748616 [details] [review]
Link to Github pull-request: https://github.com/mozilla/socorro/pull/3323
Assignee: nobody → adrian
Flags: needinfo?(adrian)

Comment 4

3 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/294847a579f1e69d26eb5a1627458c0c52e2d35a
Fixes bug 1269817 - Added a rule for signature if crash contains an IPC channel error. (#3323)

r=peterbe

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

3 years ago
That looks correct.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #6)
> That looks correct.

Do you want to file a new bug about the reprocessing? By the way, we have a simple tool now to reprocess individual crashes. You need to be a superuser but at least it's doable. We're actively working on improving that so it can allow for batch-reprocessing without superuser access needed.
(Reporter)

Updated

3 years ago
Blocks: 1270211
(Reporter)

Comment 8

3 years ago
Filed 1270211

Updated

3 years ago
Duplicate of this bug: 1268711

Updated

3 years ago
Duplicate of this bug: 1154036
(Reporter)

Comment 12

3 years ago
Jim, could you file that separately and cc me? I'd like to know how you think we should classify those crashes, since my impression is that the stacks are still pretty broken.
You need to log in before you can comment on or make changes to this bug.