If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No means by which to reset request sort order in Network panel

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED WORKSFORME
a year ago
2 months ago

People

(Reporter: ben, Unassigned)

Tracking

({nightly-community})

48 Branch
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozfr-community])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

Steps to reproduce:

This report is regarding Firefox for Developers, v 48.0a2 (2016-05-03).

If I click a column-header in the Network panel, in an effort to sort by that column, there appears to be no means by which to reset the sort-order to the default behavior (show the most recent request at the bottom of the list).


Actual results:

The Network panel becomes "stuck" in this state and all future requests are sorted by the column-header that was last clicked.


Expected results:

Firefox should have a mechanism by which to clear this sorting behavior and reset it to the default behavior.

I should add that the inability to adjust the column widths, as well as the inability to add and remove columns, is a major hindrance.

Last, but not least, I don't know what on God's green earth this browser window is doing as I type in this field, but it's pegging my CPU and lagging my keystrokes by a sentence or two at a time.
Please precise the 'Network panel'. Is this the network tab in the developer tools?
In this case, the sort order by clicking on the column header works in Nightly.
Component: Untriaged → Developer Tools: Netmonitor
Flags: needinfo?(ben)
(Reporter)

Comment 2

a year ago
Yes, Flore, that's correct; I am referring to the Network tab in the Developer Tools.

The sorting works fine; the problem is that I can't "un-sort". There appears to be no means by which to "clear" the applied sort-order.

For example, suppose I sort by request size. When I am done, how am I supposed to "clear" the sorting so that the newest request is at the bottom of the list again?
You can sort by time (which is the default sort order), so the newest request will appear at the bottom of the list.

As for the other remarks for adjusting the columns, adding or removing, you are right, it's not possible. But you should file another bug for this. In the same component (Firefox Dev tools, netmonitor) and I'll be happy to confirm it (needinfo me on it).

Same for the last issue, file another bug (different from the previous one) in the same component.

So, if you're okay with that, I'll close this bug as worksforme and you can follow the other issues on the other bugs
(Reporter)

Comment 4

a year ago
Thanks for the follow-up, Flore; I appreciate it.

You're absolutely correct. I didn't realize that the last column, which appears to be dynamically-labeled, for example, "0 ms ... 2.56 s ... 5.12 s", is a sortable column-header.

Yes, please go ahead and close with "worksforme". Thanks again for explaining how that last column works!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Whiteboard: [nightly-community],[mozfr-community]

Updated

a year ago
Keywords: nightly-community
Whiteboard: [nightly-community],[mozfr-community] → [nightly-community]

Updated

a year ago
Whiteboard: [nightly-community] → [mozfr-community]
(Reporter)

Updated

2 months ago
Flags: needinfo?(ben)
You need to log in before you can comment on or make changes to this bug.