nightly 20160503 compile fails, error: ‘nothrow_t’ in namespace ‘std’ does not name a type

RESOLVED DUPLICATE of bug 1269171

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1269171
2 years ago
4 months ago

People

(Reporter: stan, Unassigned)

Tracking

49 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8748411 [details]
Custom configuration that I am using to compile nightly

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160413095904

Steps to reproduce:

Ran mach build on the latest hg repository of nightly, using my custom .mozconfig

Using gcc 6 version 6.1.1                                                                                                                                                                                                                          


Actual results:

1:17.16 In the directory  /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/mozglue/misc
 1:17.16 The following command failed to execute properly:
 1:17.16 /usr/bin/ccache /usr/lib64/ccache/g++ -std=gnu++11 -o TimeStamp.o -c -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/s
ystem_wrappers -include /mnt/to_archive/accum/src/mozilla-central/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DIMPL_MFBT -I/mnt/to_archive/accum/src/mozilla-central/mozglue/misc -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-li
nux-gnu/mozglue/misc -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/nspr -I/mnt/to_archive/accum/src/mozilla-central/obj-x8
6_64-pc-linux-gnu/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/mozilla-config.h -MD -MP -MF .deps/TimeStamp.o.pp -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers 
-Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wc++14-compat -Wno-invalid-offsetof -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -fno-excep
tions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -Wall -fno-lifetime-dse -fno-delete-null-pointer-checks -O3 -fomit-frame-pointer -Wshadow /mnt/to_archive/accum/src/mozilla-central/mozglue/misc/TimeSt
amp.cpp
 1:17.16 /mnt/to_archive/accum/src/mozilla-central/config/rules.mk:934: recipe for target 'TimeStamp.o' failed
 1:17.16 gmake[5]: *** [TimeStamp.o] Error 1
 1:17.16 gmake[5]: *** Waiting for unfinished jobs....
 1:17.19 libfallible.a.desc
 1:17.38 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/type_traits:39:0,
 1:17.38                  from /usr/include/c++/6.1.1/bits/move.h:57,
 1:17.38                  from /usr/include/c++/6.1.1/bits/nested_exception.h:40,
 1:17.38                  from /usr/include/c++/6.1.1/exception:171,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/exception:3,
 1:17.38                  from /usr/include/c++/6.1.1/new:40,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/new:3,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/cmath:33,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/MathAlgorithms.h:15,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/FloatingPoint.h:15,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/TimeStamp.h:13,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/mozglue/misc/TimeStamp_posix.cpp:51:
 1:17.38 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:184:44: error: ‘bad_alloc’ in namespace ‘std’ does not name a type
 1:17.38  void* operator new(size_t size) MOZALLOC_THROW_BAD_ALLOC
 1:17.38                                             ^~~~~~~~~
 1:17.38 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/type_traits:39:0,
 1:17.38                  from /usr/include/c++/6.1.1/bits/move.h:57,
 1:17.38                  from /usr/include/c++/6.1.1/bits/nested_exception.h:40,
 1:17.38                  from /usr/include/c++/6.1.1/exception:171,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/exception:3,
 1:17.38                  from /usr/include/c++/6.1.1/new:40,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/new:3,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/cmath:33,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/MathAlgorithms.h:15,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/FloatingPoint.h:15,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/TimeStamp.h:13,
 1:17.38                  from /mnt/to_archive/accum/src/mozilla-central/mozglue/misc/TimeStamp_posix.cpp:51:
 1:17.38 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:190:44: error: ‘nothrow_t’ in namespace ‘std’ does not name a type
 1:17.38  void* operator new(size_t size, const std::nothrow_t&) MOZALLOC_THROW_IF_HAS_EXCEPTIONS
 1:17.39                                             ^~~~~~~~~
 1:17.39 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/type_traits:39:0,
 1:17.39                  from /usr/include/c++/6.1.1/bits/move.h:57,
 1:17.39                  from /usr/include/c++/6.1.1/bits/nested_exception.h:40,
 1:17.39                  from /usr/include/c++/6.1.1/exception:171,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/exception:3,
 1:17.39                  from /usr/include/c++/6.1.1/new:40,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/new:3,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/cmath:33,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/MathAlgorithms.h:15,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/FloatingPoint.h:15,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/TimeStamp.h:13,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/mozglue/misc/TimeStamp_posix.cpp:51:
 1:17.39 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:196:46: error: ‘bad_alloc’ in namespace ‘std’ does not name a type
 1:17.39  void* operator new[](size_t size) MOZALLOC_THROW_BAD_ALLOC
 1:17.39                                               ^~~~~~~~~
1:17.39 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/type_traits:39:0,
 1:17.39                  from /usr/include/c++/6.1.1/bits/move.h:57,
 1:17.39                  from /usr/include/c++/6.1.1/bits/nested_exception.h:40,
 1:17.39                  from /usr/include/c++/6.1.1/exception:171,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/exception:3,
 1:17.39                  from /usr/include/c++/6.1.1/new:40,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/new:3,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/cmath:33,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/MathAlgorithms.h:15,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/FloatingPoint.h:15,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/TimeStamp.h:13,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/mozglue/misc/TimeStamp_posix.cpp:51:
 1:17.39 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:202:46: error: ‘nothrow_t’ in namespace ‘std’ does not name a type
 1:17.39  void* operator new[](size_t size, const std::nothrow_t&) MOZALLOC_THROW_IF_HAS_EXCEPTIONS
 1:17.39                                               ^~~~~~~~~
 1:17.39 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/type_traits:39:0,
 1:17.39                  from /usr/include/c++/6.1.1/bits/move.h:57,
 1:17.39                  from /usr/include/c++/6.1.1/bits/nested_exception.h:40,
 1:17.39                  from /usr/include/c++/6.1.1/exception:171,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/exception:3,
 1:17.39                  from /usr/include/c++/6.1.1/new:40,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/new:3,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/cmath:33,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/MathAlgorithms.h:15,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/FloatingPoint.h:15,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/TimeStamp.h:13,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/mozglue/misc/TimeStamp_posix.cpp:51:
 1:17.39 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:214:44: error: ‘nothrow_t’ in namespace ‘std’ does not name a type
 1:17.39  void operator delete(void* ptr, const std::nothrow_t&) MOZALLOC_THROW_IF_HAS_EXCEPTIONS
 1:17.39                                             ^~~~~~~~~
 1:17.39 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/type_traits:39:0,
 1:17.39                  from /usr/include/c++/6.1.1/bits/move.h:57,
 1:17.39                  from /usr/include/c++/6.1.1/bits/nested_exception.h:40,
 1:17.39                  from /usr/include/c++/6.1.1/exception:171,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/exception:3,
 1:17.39                  from /usr/include/c++/6.1.1/new:40,
 1:17.39                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers/new:3,
 1:17.40                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers/cmath:33,
 1:17.40                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/MathAlgorithms.h:15,
 1:17.40                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/FloatingPoint.h:15,
 1:17.40                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/TimeStamp.h:13,
 1:17.40                  from /mnt/to_archive/accum/src/mozilla-central/mozglue/misc/TimeStamp_posix.cpp:51:
 1:17.40 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:226:46: error: ‘nothrow_t’ in namespace ‘std’ does not name a type
 1:17.40  void operator delete[](void* ptr, const std::nothrow_t&) MOZALLOC_THROW_IF_HAS_EXCEPTIONS
 1:17.40                                               ^~~~~~~~~
 1:17.40 
 1:17.40 In the directory  /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/mozglue/misc
 1:17.40 The following command failed to execute properly:
 1:17.40 /usr/bin/ccache /usr/lib64/ccache/g++ -std=gnu++11 -o TimeStamp_posix.o -c -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers -include /mnt/to_archive/accum/src/mozilla-central/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DIMPL_MFBT -I/mnt/to_archive/accum/src/mozilla-central/mozglue/misc -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/mozglue/misc -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/nspr -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/mozilla-config.h -MD -MP -MF .deps/TimeStamp_posix.o.pp -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wc++14-compat -Wno-invalid-offsetof -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -Wall -fno-lifetime-dse -fno-delete-null-pointer-checks -O3 -fomit-frame-pointer -Wshadow /mnt/to_archive/accum/src/mozilla-central/mozglue/misc/TimeStamp_posix.cpp
 1:17.40 /mnt/to_archive/accum/src/mozilla-central/config/rules.mk:934: recipe for target 'TimeStamp_posix.o' failed
 1:17.40 gmake[5]: *** [TimeStamp_posix.o] Error 1
 1:17.40 /mnt/to_archive/accum/src/mozilla-central/config/recurse.mk:71: recipe for target 'mozglue/misc/target' failed
 1:17.40 gmake[4]: *** [mozglue/misc/target] Error 2
 1:17.40 gmake[4]: *** Waiting for unfinished jobs....


Expected results:

PASS
PASS
(Reporter)

Updated

2 years ago
Version: 45 Branch → 49 Branch

Updated

2 years ago
Component: Untriaged → Build Config
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269171

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.